diff mbox series

[1/1] package/samba4: needs host-python3

Message ID 20200308111812.3065154-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/samba4: needs host-python3 | expand

Commit Message

Fabrice Fontaine March 8, 2020, 11:18 a.m. UTC
host-python3 is a mandatory dependency since bump to version 4.10.0 and
https://gitlab.com/samba-team/devel/samba/-/commit/5ddff307b4af5c82d5064745f5bd2c33bd340ced
because buildtools/bin/waf shebang is set to "/usr/bin/env python3"

Fixes:
 - http://autobuild.buildroot.org/results/2634eb7824beb34f485cf40670f6959515f008ad

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/samba4/samba4.mk | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

Comments

Thomas Petazzoni March 8, 2020, 2:05 p.m. UTC | #1
On Sun,  8 Mar 2020 12:18:12 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> host-python3 is a mandatory dependency since bump to version 4.10.0 and
> https://gitlab.com/samba-team/devel/samba/-/commit/5ddff307b4af5c82d5064745f5bd2c33bd340ced

This commit says:

""
Users wishing to use python2 to build need to specify PYTHON=
to both ./configure and make
""

So it seems like Python 3.x is not necessary. Have you tried that?

Thanks,

Thomas
Fabrice Fontaine March 8, 2020, 2:56 p.m. UTC | #2
Dear Thomas,

Le dim. 8 mars 2020 à 15:05, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> a écrit :
>
> On Sun,  8 Mar 2020 12:18:12 +0100
> Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
>
> > host-python3 is a mandatory dependency since bump to version 4.10.0 and
> > https://gitlab.com/samba-team/devel/samba/-/commit/5ddff307b4af5c82d5064745f5bd2c33bd340ced
>
> This commit says:
>
> ""
> Users wishing to use python2 to build need to specify PYTHON=
> to both ./configure and make
> ""
>
> So it seems like Python 3.x is not necessary. Have you tried that?
I'm not an expert in waf but we were already setting
PYTHON="$(HOST_DIR)/bin/python2" in SAMBA4_PYTHON.
SAMBA4_PYTHON is then passed to configure in SAMBA4_CONFIGURE_CMDS and
to make in SAMBA4_BUILD_CMDS.
This indeed allow the user to use python2 in configure and make but
the waf script will still mandate than python3 is installed on the
host.
It should be noted that this dependency is clearly stated in the
following commit log:
https://gitlab.com/samba-team/devel/samba/-/commit/05791f40a6e78e628ec4ab2fb0e13b2c7fbb1b78.
>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Best Regards,

Fabrice
Thomas Petazzoni March 9, 2020, 9:16 p.m. UTC | #3
On Sun,  8 Mar 2020 12:18:12 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> host-python3 is a mandatory dependency since bump to version 4.10.0 and
> https://gitlab.com/samba-team/devel/samba/-/commit/5ddff307b4af5c82d5064745f5bd2c33bd340ced
> because buildtools/bin/waf shebang is set to "/usr/bin/env python3"
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/2634eb7824beb34f485cf40670f6959515f008ad
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/samba4/samba4.mk | 11 ++++-------
>  1 file changed, 4 insertions(+), 7 deletions(-)

Applied to master, thanks.

Thomas
Thomas Petazzoni March 9, 2020, 9:16 p.m. UTC | #4
On Sun, 8 Mar 2020 15:56:11 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> I'm not an expert in waf but we were already setting
> PYTHON="$(HOST_DIR)/bin/python2" in SAMBA4_PYTHON.
> SAMBA4_PYTHON is then passed to configure in SAMBA4_CONFIGURE_CMDS and
> to make in SAMBA4_BUILD_CMDS.
> This indeed allow the user to use python2 in configure and make but
> the waf script will still mandate than python3 is installed on the
> host.
> It should be noted that this dependency is clearly stated in the
> following commit log:
> https://gitlab.com/samba-team/devel/samba/-/commit/05791f40a6e78e628ec4ab2fb0e13b2c7fbb1b78.

Thanks for the additional explanation, I've applied to master.

Thomas
Peter Korsgaard March 21, 2020, 7:17 p.m. UTC | #5
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > host-python3 is a mandatory dependency since bump to version 4.10.0 and
 > https://gitlab.com/samba-team/devel/samba/-/commit/5ddff307b4af5c82d5064745f5bd2c33bd340ced
 > because buildtools/bin/waf shebang is set to "/usr/bin/env python3"

 > Fixes:
 >  - http://autobuild.buildroot.org/results/2634eb7824beb34f485cf40670f6959515f008ad

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.02.x and 2019.11.x, thanks.
diff mbox series

Patch

diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
index 005296ea74..3048cb9a63 100644
--- a/package/samba4/samba4.mk
+++ b/package/samba4/samba4.mk
@@ -11,7 +11,7 @@  SAMBA4_INSTALL_STAGING = YES
 SAMBA4_LICENSE = GPL-3.0+
 SAMBA4_LICENSE_FILES = COPYING
 SAMBA4_DEPENDENCIES = \
-	host-e2fsprogs host-heimdal host-nfs-utils \
+	host-e2fsprogs host-heimdal host-nfs-utils host-python3 \
 	cmocka e2fsprogs gnutls popt zlib \
 	$(if $(BR2_PACKAGE_LIBAIO),libaio) \
 	$(if $(BR2_PACKAGE_LIBCAP),libcap) \
@@ -25,14 +25,11 @@  SAMBA4_CONF_ENV = \
 	XSLTPROC=false \
 	WAF_NO_PREFORK=1
 
+SAMBA4_PYTHON = PYTHON="$(HOST_DIR)/bin/python3"
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
-SAMBA4_PYTHON = \
-	PYTHON="$(HOST_DIR)/bin/python3" \
-	PYTHON_CONFIG="$(STAGING_DIR)/usr/bin/python3-config"
-SAMBA4_DEPENDENCIES += host-python3 python3
+SAMBA4_PYTHON += PYTHON_CONFIG="$(STAGING_DIR)/usr/bin/python3-config"
+SAMBA4_DEPENDENCIES += python3
 else
-SAMBA4_PYTHON = PYTHON="$(HOST_DIR)/bin/python2"
-SAMBA4_DEPENDENCIES += host-python
 SAMBA4_CONF_OPTS += --disable-python
 endif