diff mbox series

[v2,1/1] package/thrift: disable qt4

Message ID 20200307092230.1388597-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/thrift: disable qt4 | expand

Commit Message

Fabrice Fontaine March 7, 2020, 9:22 a.m. UTC
host-thrift can fail if a broken Qt4 is found on host:

CMake Error in lib/cpp/CMakeLists.txt:
  Imported target "Qt4::QtCore" includes non-existent path

    "/nvmedata/autobuild/instance-4/output-1/host/usr/mkspecs/default"

  in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:

  * The path was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and references files it does not
  provide.

Fixes:
 - http://autobuild.buildroot.org/results/57cad5313896c868e99b0b9534678f1c83a386f2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Peter Seiderer):
 - Move WITH_QT4=OFF to THRIFT_COMMON_OPTS which already contains
   WITH_QT5=OFF

 package/thrift/thrift.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Seiderer March 7, 2020, 9:50 a.m. UTC | #1
On Sat,  7 Mar 2020 10:22:30 +0100, Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> host-thrift can fail if a broken Qt4 is found on host:
>
> CMake Error in lib/cpp/CMakeLists.txt:
>   Imported target "Qt4::QtCore" includes non-existent path
>
>     "/nvmedata/autobuild/instance-4/output-1/host/usr/mkspecs/default"
>
>   in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:
>
>   * The path was deleted, renamed, or moved to another location.
>
>   * An install or uninstall procedure did not complete successfully.
>
>   * The installation package was faulty and references files it does not
>   provide.
>
> Fixes:
>  - http://autobuild.buildroot.org/results/57cad5313896c868e99b0b9534678f1c83a386f2
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Peter Seiderer <ps.report@gmx.net>

Regards,
Peter

> ---
> Changes v1 -> v2 (after review of Peter Seiderer):
>  - Move WITH_QT4=OFF to THRIFT_COMMON_OPTS which already contains
>    WITH_QT5=OFF
>
>  package/thrift/thrift.mk | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/package/thrift/thrift.mk b/package/thrift/thrift.mk
> index 6014bbfcdd..4260fe7e1c 100644
> --- a/package/thrift/thrift.mk
> +++ b/package/thrift/thrift.mk
> @@ -19,6 +19,7 @@ THRIFT_COMMON_CONF_OPTS = -DBUILD_TUTORIALS=OFF \
>  	-DBUILD_TESTING=OFF \
>  	-DWITH_PYTHON=OFF \
>  	-DWITH_JAVA=OFF \
> +	-DWITH_QT4=OFF \
>  	-DWITH_QT5=OFF
>
>  THRIFT_CONF_OPTS = $(THRIFT_COMMON_CONF_OPTS) -DBUILD_COMPILER=OFF
Thomas Petazzoni March 7, 2020, 9:52 p.m. UTC | #2
On Sat,  7 Mar 2020 10:22:30 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> host-thrift can fail if a broken Qt4 is found on host:
> 
> CMake Error in lib/cpp/CMakeLists.txt:
>   Imported target "Qt4::QtCore" includes non-existent path
> 
>     "/nvmedata/autobuild/instance-4/output-1/host/usr/mkspecs/default"
> 
>   in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:
> 
>   * The path was deleted, renamed, or moved to another location.
> 
>   * An install or uninstall procedure did not complete successfully.
> 
>   * The installation package was faulty and references files it does not
>   provide.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/57cad5313896c868e99b0b9534678f1c83a386f2
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Peter Seiderer):
>  - Move WITH_QT4=OFF to THRIFT_COMMON_OPTS which already contains
>    WITH_QT5=OFF

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/thrift/thrift.mk b/package/thrift/thrift.mk
index 6014bbfcdd..4260fe7e1c 100644
--- a/package/thrift/thrift.mk
+++ b/package/thrift/thrift.mk
@@ -19,6 +19,7 @@  THRIFT_COMMON_CONF_OPTS = -DBUILD_TUTORIALS=OFF \
 	-DBUILD_TESTING=OFF \
 	-DWITH_PYTHON=OFF \
 	-DWITH_JAVA=OFF \
+	-DWITH_QT4=OFF \
 	-DWITH_QT5=OFF
 
 THRIFT_CONF_OPTS = $(THRIFT_COMMON_CONF_OPTS) -DBUILD_COMPILER=OFF