diff mbox series

[5/5] package/pkg-meson: use TARGET_MAKE_ENV in configure

Message ID 20200204142456.1537358-6-arnout@mind.be
State Rejected
Headers show
Series Introduce cross-bin directory | expand

Commit Message

Arnout Vandecappelle Feb. 4, 2020, 2:24 p.m. UTC
The configure step doesn't use TARGET_MAKE_ENV, but sets PATH
explicitly. Thus, it missed the update of PATH with HOST_BIN_CROSS.

Instead of adding it explicitly again, just use TARGET_MAKE_ENV. Yes,
it's not really a 'make environment' that we're expecting to use in the
configure step, 'conf environment' would make more sense. However,
TARGET_MAKE_ENV is indeed used in the configure step since it's part of
TARGET_CONFIGURE_OPTS.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/pkg-meson.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/pkg-meson.mk b/package/pkg-meson.mk
index e7eea2aa58..7bb08157f5 100644
--- a/package/pkg-meson.mk
+++ b/package/pkg-meson.mk
@@ -84,7 +84,7 @@  define $(2)_CONFIGURE_CMDS
 	    ) \
 	    package/meson/cross-compilation.conf.in \
 	    > $$($$(PKG)_SRCDIR)/build/cross-compilation.conf
-	PATH=$$(BR_PATH) $$($$(PKG)_CONF_ENV) $$(MESON) \
+	$$(TARGET_MAKE_ENV) $$($$(PKG)_CONF_ENV) $$(MESON) \
 		--prefix=/usr \
 		--libdir=lib \
 		--default-library=$(if $(BR2_STATIC_LIBS),static,shared) \