diff mbox series

[2/3] package/elixir: new package

Message ID 20200129172618.16966-2-frank.vanbever@essensium.com
State Superseded
Headers show
Series [1/3] package/erlang: bump to version 22.2 | expand

Commit Message

Frank Vanbever Jan. 29, 2020, 5:26 p.m. UTC
elixir is required to build RabbitMQ starting from v3.7

Signed-off-by: Frank Vanbever <frank.vanbever@essensium.com>
---
 DEVELOPERS                 |  3 +++
 package/elixir/elixir.hash |  3 +++
 package/elixir/elixir.mk   | 21 +++++++++++++++++++++
 3 files changed, 27 insertions(+)
 create mode 100644 package/elixir/elixir.hash
 create mode 100644 package/elixir/elixir.mk

Comments

Thomas Petazzoni Feb. 1, 2020, 10:02 p.m. UTC | #1
On Wed, 29 Jan 2020 18:26:17 +0100
Frank Vanbever <frank.vanbever@essensium.com> wrote:

> +ELIXIR_VERSION = 1.9.4
> +ELIXIR_SITE = $(call github,elixir-lang,elixir,v$(ELIXIR_VERSION))
> +ELIXIR_LICENSE = Apache-2.0
> +ELIXIR_LICENSE_FILES = LICENSE
> +ELIXIR_DEPENDENCIES = erlang

It seems pretty bad/weird for a host package to depend on a target
package. We do have this situation already with host-gcc-final
depending on the target C library package.

Do you really need the target "erlang", and not just "host-erlang" ?

Best regards,

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index d5f7bdb8f7..9b9449e285 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -955,6 +955,9 @@  F:	package/ucl/
 F:	package/upx/
 F:	package/zxing-cpp/
 
+N:	Frank Vanbever <frank.vanbever@essensium.com>
+F: 	package/elixir/
+
 N:	Gaƫl Portay <gael.portay@collabora.com>
 F:	package/qt5/qt5virtualkeyboard/
 F:	package/qt5/qt5webengine/
diff --git a/package/elixir/elixir.hash b/package/elixir/elixir.hash
new file mode 100644
index 0000000000..b4d2f8b6b0
--- /dev/null
+++ b/package/elixir/elixir.hash
@@ -0,0 +1,3 @@ 
+# Computed locally
+sha256 f3465d8a8e386f3e74831bf9594ee39e6dfde6aa430fe9260844cfe46aa10139  elixir-1.9.4.tar.gz
+sha256 a6cba85bc92e0cff7a450b1d873c0eaa2e9fc96bf472df0247a26bec77bf3ff9  LICENSE
diff --git a/package/elixir/elixir.mk b/package/elixir/elixir.mk
new file mode 100644
index 0000000000..9c2dd219f8
--- /dev/null
+++ b/package/elixir/elixir.mk
@@ -0,0 +1,21 @@ 
+################################################################################
+#
+# elixir
+#
+################################################################################
+
+ELIXIR_VERSION = 1.9.4
+ELIXIR_SITE = $(call github,elixir-lang,elixir,v$(ELIXIR_VERSION))
+ELIXIR_LICENSE = Apache-2.0
+ELIXIR_LICENSE_FILES = LICENSE
+ELIXIR_DEPENDENCIES = erlang
+
+define HOST_ELIXIR_BUILD_CMDS
+	$(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) compile
+endef
+
+define HOST_ELIXIR_INSTALL_CMDS
+	$(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) PREFIX="$(HOST_DIR)" -C $(@D) install
+endef
+
+$(eval $(host-generic-package))