diff mbox series

package/iputils: use relative symlink for ping6

Message ID 20200110073359.14568-1-peter@korsgaard.com
State Accepted
Headers show
Series package/iputils: use relative symlink for ping6 | expand

Commit Message

Peter Korsgaard Jan. 10, 2020, 7:33 a.m. UTC
Fixes (part of):
http://autobuild.buildroot.net/results/5659e1c91831921bd9ad6af670258783771b4dc8/

Commit 6b37dda2a972cdf (package/iputils: create ping6 symlink), added a
ping6 symlink, but used the absolute (build) path to ping as the target,
which is naturally no good at runtime:

ls -l target/bin/ping6
lrwxrwxrwx 1 peko peko 58 Jan 10 08:25 target/bin/ping6 -> /home/peko/source/buildroot/output-iputils/target/bin/ping

Instead use a relative symlink.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/iputils/iputils.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Petr Vorel Jan. 10, 2020, 7:55 a.m. UTC | #1
Hi Peter,

> Fixes (part of):
> http://autobuild.buildroot.net/results/5659e1c91831921bd9ad6af670258783771b4dc8/

> Commit 6b37dda2a972cdf (package/iputils: create ping6 symlink), added a
> ping6 symlink, but used the absolute (build) path to ping as the target,
> which is naturally no good at runtime:

> ls -l target/bin/ping6
> lrwxrwxrwx 1 peko peko 58 Jan 10 08:25 target/bin/ping6 -> /home/peko/source/buildroot/output-iputils/target/bin/ping

> Instead use a relative symlink.

Thanks for a fix.
Reviewed-by: Petr Vorel <petr.vorel@gmail.com>

Kind regards,
Petr
Peter Korsgaard Jan. 10, 2020, 8:33 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes (part of):
 > http://autobuild.buildroot.net/results/5659e1c91831921bd9ad6af670258783771b4dc8/

 > Commit 6b37dda2a972cdf (package/iputils: create ping6 symlink), added a
 > ping6 symlink, but used the absolute (build) path to ping as the target,
 > which is naturally no good at runtime:

 > ls -l target/bin/ping6
 > lrwxrwxrwx 1 peko peko 58 Jan 10 08:25 target/bin/ping6 -> /home/peko/source/buildroot/output-iputils/target/bin/ping

 > Instead use a relative symlink.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard Jan. 10, 2020, 8:18 p.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes (part of):
 > http://autobuild.buildroot.net/results/5659e1c91831921bd9ad6af670258783771b4dc8/

 > Commit 6b37dda2a972cdf (package/iputils: create ping6 symlink), added a
 > ping6 symlink, but used the absolute (build) path to ping as the target,
 > which is naturally no good at runtime:

 > ls -l target/bin/ping6
 > lrwxrwxrwx 1 peko peko 58 Jan 10 08:25 target/bin/ping6 -> /home/peko/source/buildroot/output-iputils/target/bin/ping

 > Instead use a relative symlink.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2019.11.x, thanks.
diff mbox series

Patch

diff --git a/package/iputils/iputils.mk b/package/iputils/iputils.mk
index 5b20d4f99e..0d260891e2 100644
--- a/package/iputils/iputils.mk
+++ b/package/iputils/iputils.mk
@@ -88,7 +88,7 @@  IPUTILS_POST_INSTALL_TARGET_HOOKS += IPUTILS_MOVE_BINARIES
 
 # upstream requires distros to create symlink
 define IPUTILS_CREATE_PING6_SYMLINK
-	ln -sf $(TARGET_DIR)/bin/ping $(TARGET_DIR)/bin/ping6
+	ln -sf ping $(TARGET_DIR)/bin/ping6
 endef
 IPUTILS_POST_INSTALL_TARGET_HOOKS += IPUTILS_CREATE_PING6_SYMLINK