diff mbox series

[v3,2/3] package/solarus: allow building with lua 5.1

Message ID 20191215131358.3637959-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v3,1/3] package/solarus: bump to version 1.6.2 | expand

Commit Message

Fabrice Fontaine Dec. 15, 2019, 1:13 p.m. UTC
Build with lua 5.1 has been fixed since version 1.6.1 and
https://gitlab.com/solarus-games/solarus/commit/611f81a90d42692e986c78c67090541ffd1c5973

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Romain Naour and Peter Korsgaard):
 - Update commit title
 - Move lua dependency under !BR2_PACKAGE_LUAJIT statement

 package/solarus/Config.in  |  9 ++++-----
 package/solarus/solarus.mk | 10 +++++++++-
 2 files changed, 13 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Dec. 16, 2019, 9:53 p.m. UTC | #1
On Sun, 15 Dec 2019 14:13:57 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Build with lua 5.1 has been fixed since version 1.6.1 and
> https://gitlab.com/solarus-games/solarus/commit/611f81a90d42692e986c78c67090541ffd1c5973
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Romain Naour and Peter Korsgaard):
>  - Update commit title
>  - Move lua dependency under !BR2_PACKAGE_LUAJIT statement
> 
>  package/solarus/Config.in  |  9 ++++-----
>  package/solarus/solarus.mk | 10 +++++++++-
>  2 files changed, 13 insertions(+), 6 deletions(-)
> 
> diff --git a/package/solarus/Config.in b/package/solarus/Config.in
> index 359ad15e02..290d5a756c 100644
> --- a/package/solarus/Config.in
> +++ b/package/solarus/Config.in
> @@ -1,7 +1,7 @@
>  config BR2_PACKAGE_SOLARUS
>  	bool "solarus"
>  	depends on BR2_INSTALL_LIBSTDCPP
> -	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
> +	depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT

I am not a big fan of this change, as it could break existing setups,
so instead I've used:

	select BR2_PACKAGE_LUAJIT if !BR2_PACKAGE_LUA_5_1

and of course re-adjusted the dependencies and comments accordingly.

I've applied to master with this change.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/solarus/Config.in b/package/solarus/Config.in
index 359ad15e02..290d5a756c 100644
--- a/package/solarus/Config.in
+++ b/package/solarus/Config.in
@@ -1,7 +1,7 @@ 
 config BR2_PACKAGE_SOLARUS
 	bool "solarus"
 	depends on BR2_INSTALL_LIBSTDCPP
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+	depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT
 	depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
 	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # openal
@@ -11,7 +11,6 @@  config BR2_PACKAGE_SOLARUS
 	select BR2_PACKAGE_LIBOGG
 	select BR2_PACKAGE_LIBPNG # runtime
 	select BR2_PACKAGE_LIBVORBIS
-	select BR2_PACKAGE_LUAJIT
 	select BR2_PACKAGE_OPENAL
 	select BR2_PACKAGE_PHYSFS
 	select BR2_PACKAGE_SDL2
@@ -25,9 +24,9 @@  config BR2_PACKAGE_SOLARUS
 	  http://www.solarus-games.org
 	  https://github.com/solarus-games/solarus
 
-comment "solarus needs OpenGL and a toolchain w/ C++, gcc >= 4.8, NPTL, dynamic library"
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+comment "solarus needs OpenGL, a Lua 5.1 interpreter and a toolchain w/ C++, gcc >= 4.8, NPTL, dynamic library"
 	depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
 		|| !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS \
-		|| !BR2_PACKAGE_HAS_LIBGL
+		|| !BR2_PACKAGE_HAS_LIBGL \
+		|| !(BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT)
diff --git a/package/solarus/solarus.mk b/package/solarus/solarus.mk
index c1c2519693..d522128c33 100644
--- a/package/solarus/solarus.mk
+++ b/package/solarus/solarus.mk
@@ -16,10 +16,18 @@  SOLARUS_LICENSE_FILES = license.txt
 # Install libsolarus.so
 SOLARUS_INSTALL_STAGING = YES
 
-SOLARUS_DEPENDENCIES = libgl libmodplug libogg libvorbis luajit openal physfs sdl2 \
+SOLARUS_DEPENDENCIES = libgl libmodplug libogg libvorbis openal physfs sdl2 \
 	sdl2_image sdl2_ttf
 
 # Disable launcher GUI (requires Qt5)
 SOLARUS_CONF_OPTS = -DSOLARUS_GUI=OFF
 
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+SOLARUS_CONF_OPTS += -DSOLARUS_USE_LUAJIT=ON
+SOLARUS_DEPENDENCIES += luajit
+else
+SOLARUS_CONF_OPTS += -DSOLARUS_USE_LUAJIT=OFF
+SOLARUS_DEPENDENCIES += lua
+endif
+
 $(eval $(cmake-package))