diff mbox series

[11/12] package/perl: add missing extract dependencies

Message ID 20191210215952.902477-12-thomas.petazzoni@bootlin.com
State Superseded
Headers show
Series Ensure extractor dependencies are taken into account | expand

Commit Message

Thomas Petazzoni Dec. 10, 2019, 9:59 p.m. UTC
perl uses suitable-extractor to manually extract a tarball, so it
should have the appropriate package dependencies added to
<pkg>_EXTRACT_DEPENDENCIES.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/perl/perl.mk | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 0ab81ddb34..3b8b9fb0c4 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -27,6 +27,7 @@  define PERL_CROSS_EXTRACT
 	$(call suitable-extractor,$(PERL_CROSS_SOURCE)) $(PERL_DL_DIR)/$(PERL_CROSS_SOURCE) | \
 	$(TAR) --strip-components=1 -C $(@D) $(TAR_OPTIONS) -
 endef
+PERL_EXTRACT_DEPENDENCIES += $(call extractor-pkg-dependency,$(PERL_CROSS_SOURCE))
 PERL_POST_EXTRACT_HOOKS += PERL_CROSS_EXTRACT
 
 # Even though perl is not an autotools-package, it uses config.sub and