diff mbox series

package/pkg-generic.mk: make HOST_<pkg>_DL_OPTS inherit from <pkg>_DL_OPTS

Message ID 20191128185552.236602-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/pkg-generic.mk: make HOST_<pkg>_DL_OPTS inherit from <pkg>_DL_OPTS | expand

Commit Message

Thomas Petazzoni Nov. 28, 2019, 6:55 p.m. UTC
Just like _SITE, _SOURCE, _SITE_METHOD, it is very likely that if
<pkg>_DL_OPTS is defined, the same value should be used for
HOST_<pkg>_DL_OPTS, so let's have the same inheritance logic than the
one we have for other variables.

Fixes:

  https://bugs.busybox.net/show_bug.cgi?id=12321

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/pkg-generic.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard Nov. 29, 2019, 9:53 a.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > Just like _SITE, _SOURCE, _SITE_METHOD, it is very likely that if
 > <pkg>_DL_OPTS is defined, the same value should be used for
 > HOST_<pkg>_DL_OPTS, so let's have the same inheritance logic than the
 > one we have for other variables.

 > Fixes:

 >   https://bugs.busybox.net/show_bug.cgi?id=12321

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Given that this is only used by amd-catalyst in tree, I have applied it
to master even though we are this close to release - Thanks.
Peter Korsgaard Dec. 5, 2019, 6:37 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > Just like _SITE, _SOURCE, _SITE_METHOD, it is very likely that if
 > <pkg>_DL_OPTS is defined, the same value should be used for
 > HOST_<pkg>_DL_OPTS, so let's have the same inheritance logic than the
 > one we have for other variables.

 > Fixes:

 >   https://bugs.busybox.net/show_bug.cgi?id=12321

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2019.02.x and 2019.08.x, thanks.
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 7d6fa08418..7b3294a09a 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -541,6 +541,12 @@  ifndef $(2)_SITE_METHOD
  endif
 endif
 
+ifndef $(2)_DL_OPTS
+ ifdef $(3)_DL_OPTS
+  $(2)_DL_OPTS = $$($(3)_DL_OPTS)
+ endif
+endif
+
 ifneq ($$(filter bzr cvs hg svn,$$($(2)_SITE_METHOD)),)
 BR_NO_CHECK_HASH_FOR += $$($(2)_SOURCE)
 endif