diff mbox series

package/php: remove sample config in new location

Message ID 20191128130316.6004-1-p.debruijn@unilogic.nl
State Accepted
Headers show
Series package/php: remove sample config in new location | expand

Commit Message

Pascal de Bruijn Nov. 28, 2019, 1:03 p.m. UTC
From: Pascal de Bruijn <pmjdebruijn@pcode.nl>

the upstream php-fpm sample configuration is placed in

  /etc/php-fpm.d/www.conf.default

in recent version of php, so adjust the build cleanup
accordingly

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
---
 package/php/php.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Dec. 31, 2019, 5:27 p.m. UTC | #1
Pascal, All,

On 2019-11-28 14:03 +0100, Pascal de Bruijn spake thusly:
> From: Pascal de Bruijn <pmjdebruijn@pcode.nl>
> 
> the upstream php-fpm sample configuration is placed in
> 
>   /etc/php-fpm.d/www.conf.default
> 
> in recent version of php, so adjust the build cleanup
> accordingly
> 
> Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
> ---
>  package/php/php.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/php/php.mk b/package/php/php.mk
> index 007b8a6..c83f04a 100644
> --- a/package/php/php.mk
> +++ b/package/php/php.mk
> @@ -346,7 +346,7 @@ endef
>  define PHP_INSTALL_FPM_CONF
>  	$(INSTALL) -D -m 0644 package/php/php-fpm.conf \
>  		$(TARGET_DIR)/etc/php-fpm.conf
> -	rm -f $(TARGET_DIR)/etc/php-fpm.conf.default
> +	rm -rf $(TARGET_DIR)/etc/php-fpm.d

I've changed that to only remove the file, not the whole directory, in
case an other (built earlier) package installs files there.

Applied to master with that fix, thanks.

Regards,
Yann E. MORIN.

>  	# remove unused sample status page /usr/php/php/fpm/status.html
>  	rm -rf $(TARGET_DIR)/usr/php
>  endef
> -- 
> 2.7.4
> 
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index 007b8a6..c83f04a 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -346,7 +346,7 @@  endef
 define PHP_INSTALL_FPM_CONF
 	$(INSTALL) -D -m 0644 package/php/php-fpm.conf \
 		$(TARGET_DIR)/etc/php-fpm.conf
-	rm -f $(TARGET_DIR)/etc/php-fpm.conf.default
+	rm -rf $(TARGET_DIR)/etc/php-fpm.d
 	# remove unused sample status page /usr/php/php/fpm/status.html
 	rm -rf $(TARGET_DIR)/usr/php
 endef