diff mbox series

[1/1] package/iputils: fix service installation

Message ID 20191102151726.7341-1-petr.vorel@gmail.com
State Changes Requested
Headers show
Series [1/1] package/iputils: fix service installation | expand

Commit Message

Petr Vorel Nov. 2, 2019, 3:17 p.m. UTC
service files aren't installed by meson for some reason,
thus install them manually.
This is temporary fix, until it's fixed upstream.
It might be caused by install_dir ignoring the prefix and installing
always into systemd.get_pkgconfig_variable('systemdsystemunitdir').

Fixes: ada815afcf ("package/iputils: enable systemd services")

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
Quick fix, going to submit solution to upstream.
Feel free to wait for proper fix.

Kind regards,
Petr

 package/iputils/iputils.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Nov. 2, 2019, 9:27 p.m. UTC | #1
Hello Petr,

On Sat,  2 Nov 2019 16:17:26 +0100
Petr Vorel <petr.vorel@gmail.com> wrote:

>  define IPUTILS_INSTALL_SERVICE_NINFOD
> +	$(INSTALL) -D -m 0644 $(@D)/systemd/ninfod.service.in \
> +		$(TARGET_DIR)/usr/lib/systemd/system/ninfod.service

This cannot be right: ninfod.service.in contains @sbindir@ that needs
to be replaced before being installed.

>  define IPUTILS_INSTALL_SERVICE_RDISC
> +	$(INSTALL) -D -m 0644 $(@D)/systemd/rdisc.service.in \
> +		$(TARGET_DIR)/usr/lib/systemd/system/rdisc.service

Ditto.

Best regards,

Thomas
James Hilliard Nov. 2, 2019, 9:43 p.m. UTC | #2
On Sat, Nov 2, 2019 at 11:17 AM Petr Vorel <petr.vorel@gmail.com> wrote:
>
> service files aren't installed by meson for some reason,
> thus install them manually.
Are you sure? When I was testing my service symlink patch they were
being installed, they were just not being enabled.
> This is temporary fix, until it's fixed upstream.
> It might be caused by install_dir ignoring the prefix and installing
> always into systemd.get_pkgconfig_variable('systemdsystemunitdir').
>
> Fixes: ada815afcf ("package/iputils: enable systemd services")
>
> Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
> ---
> Quick fix, going to submit solution to upstream.
> Feel free to wait for proper fix.
>
> Kind regards,
> Petr
>
>  package/iputils/iputils.mk | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/package/iputils/iputils.mk b/package/iputils/iputils.mk
> index 57e90a973a..98f6f60dfe 100644
> --- a/package/iputils/iputils.mk
> +++ b/package/iputils/iputils.mk
> @@ -59,6 +59,8 @@ IPUTILS_CONF_OPTS += -DBUILD_NINFOD=false
>  else
>  IPUTILS_CONF_OPTS += -DBUILD_NINFOD=true
>  define IPUTILS_INSTALL_SERVICE_NINFOD
> +       $(INSTALL) -D -m 0644 $(@D)/systemd/ninfod.service.in \
> +               $(TARGET_DIR)/usr/lib/systemd/system/ninfod.service
>         mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
>         ln -sf ../../../../lib/systemd/system/ninfod.service \
>                 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ninfod.service
> @@ -115,6 +117,8 @@ endef
>  endif
>
>  define IPUTILS_INSTALL_SERVICE_RDISC
> +       $(INSTALL) -D -m 0644 $(@D)/systemd/rdisc.service.in \
> +               $(TARGET_DIR)/usr/lib/systemd/system/rdisc.service
>         mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
>         ln -sf ../../../../lib/systemd/system/rdisc.service \
>                 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rdisc.service
> --
> 2.24.0.rc2
>
Petr Vorel Nov. 3, 2019, 5:51 a.m. UTC | #3
Hi Thomas,

> >  define IPUTILS_INSTALL_SERVICE_NINFOD
> > +	$(INSTALL) -D -m 0644 $(@D)/systemd/ninfod.service.in \
> > +		$(TARGET_DIR)/usr/lib/systemd/system/ninfod.service

> This cannot be right: ninfod.service.in contains @sbindir@ that needs
> to be replaced before being installed.
I'm sorry to overlook that. If it's ok to be replaced by sed/awk
I'll send a new patch.
Or we can wait for a proper fix in upstream.

Kind regards,
Petr
James Hilliard Nov. 3, 2019, 6:09 a.m. UTC | #4
On Sat, Nov 2, 2019 at 11:17 AM Petr Vorel <petr.vorel@gmail.com> wrote:
>
> service files aren't installed by meson for some reason,
> thus install them manually.
This should hopefully fix it:
https://patchwork.ozlabs.org/patch/1188505/
> This is temporary fix, until it's fixed upstream.
> It might be caused by install_dir ignoring the prefix and installing
> always into systemd.get_pkgconfig_variable('systemdsystemunitdir').
>
> Fixes: ada815afcf ("package/iputils: enable systemd services")
>
> Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
> ---
> Quick fix, going to submit solution to upstream.
> Feel free to wait for proper fix.
>
> Kind regards,
> Petr
>
>  package/iputils/iputils.mk | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/package/iputils/iputils.mk b/package/iputils/iputils.mk
> index 57e90a973a..98f6f60dfe 100644
> --- a/package/iputils/iputils.mk
> +++ b/package/iputils/iputils.mk
> @@ -59,6 +59,8 @@ IPUTILS_CONF_OPTS += -DBUILD_NINFOD=false
>  else
>  IPUTILS_CONF_OPTS += -DBUILD_NINFOD=true
>  define IPUTILS_INSTALL_SERVICE_NINFOD
> +       $(INSTALL) -D -m 0644 $(@D)/systemd/ninfod.service.in \
> +               $(TARGET_DIR)/usr/lib/systemd/system/ninfod.service
>         mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
>         ln -sf ../../../../lib/systemd/system/ninfod.service \
>                 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ninfod.service
> @@ -115,6 +117,8 @@ endef
>  endif
>
>  define IPUTILS_INSTALL_SERVICE_RDISC
> +       $(INSTALL) -D -m 0644 $(@D)/systemd/rdisc.service.in \
> +               $(TARGET_DIR)/usr/lib/systemd/system/rdisc.service
>         mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
>         ln -sf ../../../../lib/systemd/system/rdisc.service \
>                 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rdisc.service
> --
> 2.24.0.rc2
>
diff mbox series

Patch

diff --git a/package/iputils/iputils.mk b/package/iputils/iputils.mk
index 57e90a973a..98f6f60dfe 100644
--- a/package/iputils/iputils.mk
+++ b/package/iputils/iputils.mk
@@ -59,6 +59,8 @@  IPUTILS_CONF_OPTS += -DBUILD_NINFOD=false
 else
 IPUTILS_CONF_OPTS += -DBUILD_NINFOD=true
 define IPUTILS_INSTALL_SERVICE_NINFOD
+	$(INSTALL) -D -m 0644 $(@D)/systemd/ninfod.service.in \
+		$(TARGET_DIR)/usr/lib/systemd/system/ninfod.service
 	mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
 	ln -sf ../../../../lib/systemd/system/ninfod.service \
 		$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ninfod.service
@@ -115,6 +117,8 @@  endef
 endif
 
 define IPUTILS_INSTALL_SERVICE_RDISC
+	$(INSTALL) -D -m 0644 $(@D)/systemd/rdisc.service.in \
+		$(TARGET_DIR)/usr/lib/systemd/system/rdisc.service
 	mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
 	ln -sf ../../../../lib/systemd/system/rdisc.service \
 		$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rdisc.service