diff mbox series

package/softether: remove 'v' prefix from github-fetched packages

Message ID 20191027063929.14361-1-matthew.weber@rockwellcollins.com
State Changes Requested
Headers show
Series package/softether: remove 'v' prefix from github-fetched packages | expand

Commit Message

Matt Weber Oct. 27, 2019, 6:39 a.m. UTC
Fixes version parsing for release-monitoring.org support.

Cc: Heiko Thiery <heiko.thiery@kontron.com>
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>

---
Thanks Heiko for the script that found this one!
---
 package/softether/softether.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Heiko Thiery Oct. 27, 2019, 7:55 a.m. UTC | #1
utils/test-pkg -k -p softether fails

ERROR: No hash found for pru-software-support-5.1.0.tar.gz
make: *** [package/pkg-generic.mk:146: /home/hthiery/br-test-pkg/br-arm-full/build/host-pru-software-support-5.1.0/.stamp_downloaded] Fehler 1

I think the problem is when <pkg>_SOURCE is not explicitly specified it will be generated with the $(VERSION) without the 'v' that does not match the filename in the hash file.


--

Heiko
Peter Korsgaard Oct. 27, 2019, 9:13 a.m. UTC | #2
>>>>> "Heiko" == Heiko Thiery <Heiko.Thiery@kontron.com> writes:

 > utils/test-pkg -k -p softether fails
 > ERROR: No hash found for pru-software-support-5.1.0.tar.gz
 > make: *** [package/pkg-generic.mk:146:
 > /home/hthiery/br-test-pkg/br-arm-full/build/host-pru-software-support-5.1.0/.stamp_downloaded]
 > Fehler 1

 > I think the problem is when <pkg>_SOURCE is not explicitly specified
 > it will be generated with the $(VERSION) without the 'v' that does not
 > match the filename in the hash file.

Indeed. Matt, will you fix up the .hash files of all of these and
resend? In the mean time I will mark these as changes requested.
diff mbox series

Patch

diff --git a/package/softether/softether.mk b/package/softether/softether.mk
index 1a31abd4bd..b7c6738b9a 100644
--- a/package/softether/softether.mk
+++ b/package/softether/softether.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-SOFTETHER_VERSION = v4.28-9669-beta
-SOFTETHER_SITE = $(call github,SoftEtherVPN,SoftEtherVPN_stable,$(SOFTETHER_VERSION))
+SOFTETHER_VERSION = 4.28-9669-beta
+SOFTETHER_SITE = $(call github,SoftEtherVPN,SoftEtherVPN_stable,v$(SOFTETHER_VERSION))
 SOFTETHER_LICENSE = GPL-2.0
 SOFTETHER_LICENSE_FILES = LICENSE
 SOFTETHER_DEPENDENCIES = host-pkgconf host-softether libopenssl readline