diff mbox series

[1/1] package/lld: fix build with gcc < 5.1

Message ID 20191024231818.988900-1-joseph.kogut@gmail.com
State Accepted
Commit 393938f04faaf06d35366450c498847507ef72e3
Headers show
Series [1/1] package/lld: fix build with gcc < 5.1 | expand

Commit Message

Joseph Kogut Oct. 24, 2019, 11:18 p.m. UTC
This fix is based on commit 2a17fb6 used for llvm.

Fixes:
http://autobuild.buildroot.net/results/76310241a335a99a4ff2726edb517b067367fd41
http://autobuild.buildroot.net/results/88cbfae219fd4475be376c9558b5760cebd2148f
Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
---
 package/lld/lld.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Romain Naour Oct. 25, 2019, 7:44 a.m. UTC | #1
Hi Joseph,

Le 25/10/2019 à 01:18, Joseph Kogut a écrit :
> This fix is based on commit 2a17fb6 used for llvm.
> 
> Fixes:
> http://autobuild.buildroot.net/results/76310241a335a99a4ff2726edb517b067367fd41
> http://autobuild.buildroot.net/results/88cbfae219fd4475be376c9558b5760cebd2148f
> Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
> ---
>  package/lld/lld.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/package/lld/lld.mk b/package/lld/lld.mk
> index cd76c724ce..c284d6df7f 100644
> --- a/package/lld/lld.mk
> +++ b/package/lld/lld.mk
> @@ -13,6 +13,12 @@ LLD_LICENSE_FILES = LICENSE.TXT
>  LLD_SUPPORTS_IN_SOURCE_BUILD = NO
>  HOST_LLD_DEPENDENCIES = host-llvm
>  
> +# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
> +# toolchain using gcc < 5.1 gives an error but actually still works. Setting
> +# this option makes it still build with gcc >= 4.8.
> +# https://reviews.llvm.org/D57264

At the time this comment was written, I supposed that llvm >= 9.0 will require
C++14. But llvm 9.0 was released with this option, so in practice we can still
use gcc < 5.1 to build llvm. Maybe this comment should be updated.

Otherwise:
Reviewed-by: Romain Naour <romain.naour@smile.fr>

Best regards,
Romain

> +HOST_LLD_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
> +
>  # GCC looks for tools in a different path from LLD's default installation path
>  define HOST_LLD_CREATE_SYMLINKS
>  	mkdir -p $(HOST_DIR)/$(GNU_TARGET_NAME)/bin
>
Peter Korsgaard Oct. 25, 2019, 8:31 a.m. UTC | #2
>>>>> "Joseph" == Joseph Kogut <joseph.kogut@gmail.com> writes:

 > This fix is based on commit 2a17fb6 used for llvm.
 > Fixes:
 > http://autobuild.buildroot.net/results/76310241a335a99a4ff2726edb517b067367fd41
 > http://autobuild.buildroot.net/results/88cbfae219fd4475be376c9558b5760cebd2148f
 > Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
 > ---
 >  package/lld/lld.mk | 6 ++++++
 >  1 file changed, 6 insertions(+)

 > diff --git a/package/lld/lld.mk b/package/lld/lld.mk
 > index cd76c724ce..c284d6df7f 100644
 > --- a/package/lld/lld.mk
 > +++ b/package/lld/lld.mk
 > @@ -13,6 +13,12 @@ LLD_LICENSE_FILES = LICENSE.TXT
 >  LLD_SUPPORTS_IN_SOURCE_BUILD = NO
 >  HOST_LLD_DEPENDENCIES = host-llvm
 
 > +# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
 > +# toolchain using gcc < 5.1 gives an error but actually still works. Setting
 > +# this option makes it still build with gcc >= 4.8.
 > +# https://reviews.llvm.org/D57264
 > +HOST_LLD_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
 > +

Committed after adjusting the comment as suggested by Romain, thanks.
diff mbox series

Patch

diff --git a/package/lld/lld.mk b/package/lld/lld.mk
index cd76c724ce..c284d6df7f 100644
--- a/package/lld/lld.mk
+++ b/package/lld/lld.mk
@@ -13,6 +13,12 @@  LLD_LICENSE_FILES = LICENSE.TXT
 LLD_SUPPORTS_IN_SOURCE_BUILD = NO
 HOST_LLD_DEPENDENCIES = host-llvm
 
+# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
+# toolchain using gcc < 5.1 gives an error but actually still works. Setting
+# this option makes it still build with gcc >= 4.8.
+# https://reviews.llvm.org/D57264
+HOST_LLD_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+
 # GCC looks for tools in a different path from LLD's default installation path
 define HOST_LLD_CREATE_SYMLINKS
 	mkdir -p $(HOST_DIR)/$(GNU_TARGET_NAME)/bin