diff mbox series

[1/1] Makefile: add help for show-targets command

Message ID 20190812194758.1287-1-vadim4j@gmail.com
State Rejected
Headers show
Series [1/1] Makefile: add help for show-targets command | expand

Commit Message

Vadym Kochan Aug. 12, 2019, 7:47 p.m. UTC
Add help output for "show-targets" command.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
---
 Makefile | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Aug. 12, 2019, 8:43 p.m. UTC | #1
Hello Vadim,

+Yann in Cc to gather his opinion.

On Mon, 12 Aug 2019 22:47:58 +0300
Vadim Kochan <vadim4j@gmail.com> wrote:

> Add help output for "show-targets" command.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> ---
>  Makefile | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Makefile b/Makefile
> index 406efd1ab6..8d2070b5d0 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -1132,6 +1132,7 @@ help:
>  	@echo '  legal-info             - generate info about license compliance'
>  	@echo '  show-info              - generate info about packages, as a JSON blurb'
>  	@echo '  printvars              - dump internal variables selected with VARS=...'
> +	@echo '  show-targets           - list targets of selected packages'

It does not show only packages, but also rootfs images that will be generated.

I don't know if we want to document this target, it's really an
"internal" one. It used to be used by some scripts, but with the new
JSON show-info, show-targets is no longer used.

We could even get rid of it in fact.

Thomas
Arnout Vandecappelle Aug. 26, 2019, 7:53 p.m. UTC | #2
On 12/08/2019 22:43, Thomas Petazzoni wrote:
> Hello Vadim,
> 
> +Yann in Cc to gather his opinion.
> 
> On Mon, 12 Aug 2019 22:47:58 +0300
> Vadim Kochan <vadim4j@gmail.com> wrote:
> 
>> Add help output for "show-targets" command.
>>
>> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
>> ---
>>  Makefile | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/Makefile b/Makefile
>> index 406efd1ab6..8d2070b5d0 100644
>> --- a/Makefile
>> +++ b/Makefile
>> @@ -1132,6 +1132,7 @@ help:
>>  	@echo '  legal-info             - generate info about license compliance'
>>  	@echo '  show-info              - generate info about packages, as a JSON blurb'
>>  	@echo '  printvars              - dump internal variables selected with VARS=...'
>> +	@echo '  show-targets           - list targets of selected packages'
> 
> It does not show only packages, but also rootfs images that will be generated.
> 
> I don't know if we want to document this target, it's really an
> "internal" one. It used to be used by some scripts, but with the new
> JSON show-info, show-targets is no longer used.
> 
> We could even get rid of it in fact.

 +1 to get rid of it.

 Regards,
 Arnout
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index 406efd1ab6..8d2070b5d0 100644
--- a/Makefile
+++ b/Makefile
@@ -1132,6 +1132,7 @@  help:
 	@echo '  legal-info             - generate info about license compliance'
 	@echo '  show-info              - generate info about packages, as a JSON blurb'
 	@echo '  printvars              - dump internal variables selected with VARS=...'
+	@echo '  show-targets           - list targets of selected packages'
 	@echo
 	@echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'
 	@echo '  make O=dir             - Locate all output files in "dir", including .config'