diff mbox series

[2/2] package/brotli: work aroung gcc bug 68485

Message ID 20190527210510.70987-2-giulio.benetti@micronovasrl.com
State Superseded
Headers show
Series [1/2] toolchain: GCC bug 68485 | expand

Commit Message

Giulio Benetti May 27, 2019, 9:05 p.m. UTC
With Microblaze Gcc version <= 9.x the build hangs due to gcc bug 68485:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
building brotli with optimization but not when building with -O0. To
work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
-O0.

Fixes:

  http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/brotli/brotli.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Arnout Vandecappelle May 27, 2019, 9:18 p.m. UTC | #1
On 27/05/2019 23:05, Giulio Benetti wrote:
> With Microblaze Gcc version <= 9.x the build hangs due to gcc bug 68485:
                                               ^^^^^
 fails, not hangs

> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
> building brotli with optimization but not when building with -O0. To
> work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
> -O0.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---
>  package/brotli/brotli.mk | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
> index 2c1ad48753..248bfb9daf 100644
> --- a/package/brotli/brotli.mk
> +++ b/package/brotli/brotli.mk
> @@ -14,4 +14,8 @@ BROTLI_CONF_OPTS = \
>  	-DBROTLI_DISABLE_TESTS=ON \
>  	-DBROTLI_BUNDLED_MODE=OFF
>  
> +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)

 Could you also update package/gpsd/gpsd.mk in the same way? It's the package
which triggered the original bug report, and it still disables it for microblaze
entirely.

 Regards,
 Arnout

> +BROTLI_CONF_OPTS += -DCMAKE_C_FLAGS="-O0"
> +endif
> +
>  $(eval $(cmake-package))
>
Giulio Benetti May 27, 2019, 9:22 p.m. UTC | #2
Il 27/05/2019 23:18, Arnout Vandecappelle ha scritto:
> 
> 
> On 27/05/2019 23:05, Giulio Benetti wrote:
>> With Microblaze Gcc version <= 9.x the build hangs due to gcc bug 68485:
>                                                 ^^^^^
>   fails, not hangs

Oops. Right.

>> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
>> building brotli with optimization but not when building with -O0. To
>> work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
>> -O0.
>>
>> Fixes:
>>
>>    http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/
>>
>> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
>> ---
>>   package/brotli/brotli.mk | 4 ++++
>>   1 file changed, 4 insertions(+)
>>
>> diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
>> index 2c1ad48753..248bfb9daf 100644
>> --- a/package/brotli/brotli.mk
>> +++ b/package/brotli/brotli.mk
>> @@ -14,4 +14,8 @@ BROTLI_CONF_OPTS = \
>>   	-DBROTLI_DISABLE_TESTS=ON \
>>   	-DBROTLI_BUNDLED_MODE=OFF
>>   
>> +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
> 
>   Could you also update package/gpsd/gpsd.mk in the same way? It's the package
> which triggered the original bug report, and it still disables it for microblaze
> entirely.
> 

Sure, it was already ready to tell the truth, but I have too many 
patches in WIP.
There are also, flann and libspatialindex.
I'm going to send all together then.

Thank you

Kind regards
diff mbox series

Patch

diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
index 2c1ad48753..248bfb9daf 100644
--- a/package/brotli/brotli.mk
+++ b/package/brotli/brotli.mk
@@ -14,4 +14,8 @@  BROTLI_CONF_OPTS = \
 	-DBROTLI_DISABLE_TESTS=ON \
 	-DBROTLI_BUNDLED_MODE=OFF
 
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+BROTLI_CONF_OPTS += -DCMAKE_C_FLAGS="-O0"
+endif
+
 $(eval $(cmake-package))