diff mbox series

[1/1] package/qt5multimedia: fix install with gstreamer 0.10 and QT 5.6

Message ID 20190526172033.22792-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/qt5multimedia: fix install with gstreamer 0.10 and QT 5.6 | expand

Commit Message

Fabrice Fontaine May 26, 2019, 5:20 p.m. UTC
QT 5.6 fails to correctly detect gstreamer support with gstreamer 0.10
as a result libqgsttools_p.so is not built and build fails on:
cp: cannot stat '/home/buildroot/autobuild/run/instance-1/output/host/xtensa-buildroot-linux-uclibc/sysroot/usr/lib/libqgsttools*.so.*': No such file or directory

Fixes:
 - http://autobuild.buildroot.org/results/c88afcd365418e29c89f247d9d887b5f786b0ec8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/qt5/qt5multimedia/qt5multimedia.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle May 26, 2019, 6:05 p.m. UTC | #1
On 26/05/2019 19:20, Fabrice Fontaine wrote:
> QT 5.6 fails to correctly detect gstreamer support with gstreamer 0.10
> as a result libqgsttools_p.so is not built and build fails on:
> cp: cannot stat '/home/buildroot/autobuild/run/instance-1/output/host/xtensa-buildroot-linux-uclibc/sysroot/usr/lib/libqgsttools*.so.*': No such file or directory
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/c88afcd365418e29c89f247d9d887b5f786b0ec8
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks.

 Regards,
 Arnout

> ---
>  package/qt5/qt5multimedia/qt5multimedia.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/qt5/qt5multimedia/qt5multimedia.mk b/package/qt5/qt5multimedia/qt5multimedia.mk
> index 0a27c857e5..b8a1c4ff75 100644
> --- a/package/qt5/qt5multimedia/qt5multimedia.mk
> +++ b/package/qt5/qt5multimedia/qt5multimedia.mk
> @@ -53,7 +53,7 @@ endef
>  ifeq ($(BR2_STATIC_LIBS),)
>  # since Qt5.10.1 libqgsttools was renamed to libQtMultimediaGstTools
>  # and is installed by the default target install step below
> -ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST)x$(BR2_PACKAGE_GST_PLUGINS_BASE)$(BR2_PACKAGE_GST1_PLUGINS_BASE),xy)
> +ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST)x$(BR2_PACKAGE_GST1_PLUGINS_BASE),xy)
>  define QT5MULTIMEDIA_INSTALL_TARGET_QGSTTOOLS_LIB
>  	cp -dpf $(STAGING_DIR)/usr/lib/libqgsttools*.so.* $(TARGET_DIR)/usr/lib
>  endef
>
diff mbox series

Patch

diff --git a/package/qt5/qt5multimedia/qt5multimedia.mk b/package/qt5/qt5multimedia/qt5multimedia.mk
index 0a27c857e5..b8a1c4ff75 100644
--- a/package/qt5/qt5multimedia/qt5multimedia.mk
+++ b/package/qt5/qt5multimedia/qt5multimedia.mk
@@ -53,7 +53,7 @@  endef
 ifeq ($(BR2_STATIC_LIBS),)
 # since Qt5.10.1 libqgsttools was renamed to libQtMultimediaGstTools
 # and is installed by the default target install step below
-ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST)x$(BR2_PACKAGE_GST_PLUGINS_BASE)$(BR2_PACKAGE_GST1_PLUGINS_BASE),xy)
+ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST)x$(BR2_PACKAGE_GST1_PLUGINS_BASE),xy)
 define QT5MULTIMEDIA_INSTALL_TARGET_QGSTTOOLS_LIB
 	cp -dpf $(STAGING_DIR)/usr/lib/libqgsttools*.so.* $(TARGET_DIR)/usr/lib
 endef