diff mbox series

[1/1] package/gpsd: fix BR2_PACKAGE_GPSD_MAX_{CLIENT, DEV} options

Message ID 20190525135241.9208-1-fontaine.fabrice@gmail.com
State Accepted
Commit 87cc11688d9f8bd88ef45643961255d0bfa2d67b
Headers show
Series [1/1] package/gpsd: fix BR2_PACKAGE_GPSD_MAX_{CLIENT, DEV} options | expand

Commit Message

Fabrice Fontaine May 25, 2019, 1:52 p.m. UTC
limited_max_clients and limited_max_devices have been renamed in 3.12
as max_clients and max_devices, respectively.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gpsd/gpsd.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Benoît Thébaudeau May 25, 2019, 2:13 p.m. UTC | #1
Dear Fabrice,

On Sat, May 25, 2019 at 3:52 PM Fabrice Fontaine
<fontaine.fabrice@gmail.com> wrote:
>
> limited_max_clients and limited_max_devices have been renamed in 3.12
> as max_clients and max_devices, respectively.
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gpsd/gpsd.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
> index 0a17ddc93e..d2c7612526 100644
> --- a/package/gpsd/gpsd.mk
> +++ b/package/gpsd/gpsd.mk
> @@ -195,10 +195,10 @@ ifeq ($(BR2_PACKAGE_GPSD_FIXED_PORT_SPEED),y)
>  GPSD_SCONS_OPTS += fixed_port_speed=$(BR2_PACKAGE_GPSD_FIXED_PORT_SPEED_VALUE)
>  endif
>  ifeq ($(BR2_PACKAGE_GPSD_MAX_CLIENT),y)
> -GPSD_SCONS_OPTS += limited_max_clients=$(BR2_PACKAGE_GPSD_MAX_CLIENT_VALUE)
> +GPSD_SCONS_OPTS += max_clients=$(BR2_PACKAGE_GPSD_MAX_CLIENT_VALUE)
>  endif
>  ifeq ($(BR2_PACKAGE_GPSD_MAX_DEV),y)
> -GPSD_SCONS_OPTS += limited_max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
> +GPSD_SCONS_OPTS += max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
>  endif
>
>  GPSD_SCONS_ENV += LDFLAGS="$(GPSD_LDFLAGS)" CFLAGS="$(GPSD_CFLAGS)"
> --
> 2.20.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

Reviewed-by: Benoît Thébaudeau <benoit.thebaudeau.dev@gmail.com>

Best regards,
Benoît
Peter Korsgaard May 25, 2019, 9:16 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > limited_max_clients and limited_max_devices have been renamed in 3.12
 > as max_clients and max_devices, respectively.

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard June 6, 2019, 3:07 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > limited_max_clients and limited_max_devices have been renamed in 3.12
 > as max_clients and max_devices, respectively.

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index 0a17ddc93e..d2c7612526 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -195,10 +195,10 @@  ifeq ($(BR2_PACKAGE_GPSD_FIXED_PORT_SPEED),y)
 GPSD_SCONS_OPTS += fixed_port_speed=$(BR2_PACKAGE_GPSD_FIXED_PORT_SPEED_VALUE)
 endif
 ifeq ($(BR2_PACKAGE_GPSD_MAX_CLIENT),y)
-GPSD_SCONS_OPTS += limited_max_clients=$(BR2_PACKAGE_GPSD_MAX_CLIENT_VALUE)
+GPSD_SCONS_OPTS += max_clients=$(BR2_PACKAGE_GPSD_MAX_CLIENT_VALUE)
 endif
 ifeq ($(BR2_PACKAGE_GPSD_MAX_DEV),y)
-GPSD_SCONS_OPTS += limited_max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
+GPSD_SCONS_OPTS += max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
 endif
 
 GPSD_SCONS_ENV += LDFLAGS="$(GPSD_LDFLAGS)" CFLAGS="$(GPSD_CFLAGS)"