diff mbox series

[v2,7/7] package/flashbench: remove old check if BR2_microblaze & BR2_sh2a

Message ID 20190522135906.30796-8-giulio.benetti@micronovasrl.com
State Changes Requested
Headers show
Series fix GCC BUG 85180 and 85862 | expand

Commit Message

Giulio Benetti May 22, 2019, 1:59 p.m. UTC
Commit:
https://git.buildroot.net/buildroot/commit/?id=bad25aff36b70b55b34ea4580b45f657385ae9ac
removed sourcery toolchain already deprecated in 2014 causing build
failure. It was based on Gcc 4.6.2 and Buildroot doesn't use this
anymore.

Remove check against BR2_microblaze and BR2_sh2a.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/flashbench/flashbench.mk | 5 -----
 1 file changed, 5 deletions(-)

Comments

Thomas Petazzoni May 24, 2019, 9:18 p.m. UTC | #1
Hello,

On Wed, 22 May 2019 15:59:06 +0200
Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:

> Commit:
> https://git.buildroot.net/buildroot/commit/?id=bad25aff36b70b55b34ea4580b45f657385ae9ac
> removed sourcery toolchain already deprecated in 2014 causing build
> failure. It was based on Gcc 4.6.2 and Buildroot doesn't use this
> anymore.

This explanation is quite fuzzy. What is the relationship between the
removal of those toolchains and this particular issue ? Also this
commit only removes Microblaze toolchains, not SH2A toolchains.

Since when the LLONG_MAX issue has been fixed ?

Best regards,

Thomas
Giulio Benetti May 28, 2019, 8:58 a.m. UTC | #2
Hello Thomas,

Il 24/05/2019 23:18, Thomas Petazzoni ha scritto:
> Hello,
> 
> On Wed, 22 May 2019 15:59:06 +0200
> Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:
> 
>> Commit:
>> https://git.buildroot.net/buildroot/commit/?id=bad25aff36b70b55b34ea4580b45f657385ae9ac
>> removed sourcery toolchain already deprecated in 2014 causing build
>> failure. It was based on Gcc 4.6.2 and Buildroot doesn't use this
>> anymore.
> 
> This explanation is quite fuzzy. What is the relationship between the
> removal of those toolchains and this particular issue ? 

I improve commit log.

>Also this commit only removes Microblaze toolchains, not SH2A toolchains.

I've messed up, I need to remove BR2_microblaze only.

> Since when the LLONG_MAX issue has been fixed ?

Need to check and report on commit log.

Best regards
diff mbox series

Patch

diff --git a/package/flashbench/flashbench.mk b/package/flashbench/flashbench.mk
index cbcf9ea2d1..e5c6b97283 100644
--- a/package/flashbench/flashbench.mk
+++ b/package/flashbench/flashbench.mk
@@ -11,11 +11,6 @@  FLASHBENCH_LICENSE_FILES = COPYING
 
 FLASHBENCH_CFLAGS = $(TARGET_CFLAGS)
 
-ifeq ($(BR2_microblaze)$(BR2_sh2a),y)
-# microblaze and sh2a toolchains only provide LLONG_MAX when used with gnu99 dialect
-FLASHBENCH_CFLAGS += -std=gnu99
-endif
-
 define FLASHBENCH_BUILD_CMDS
 	$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
 		CFLAGS="$(FLASHBENCH_CFLAGS)" \