diff mbox series

[1/1] package/ipsec-tools: fix static build with openssl and atomic

Message ID 20190413084912.8000-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/ipsec-tools: fix static build with openssl and atomic | expand

Commit Message

Fabrice Fontaine April 13, 2019, 8:49 a.m. UTC
Use pkg-config to find openssl dependencies such as lz or latomic

Fix static build on sparc v8 (even if there is no autobuilder failures
yet)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/ipsec-tools/ipsec-tools.mk | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

Comments

Arnout Vandecappelle April 13, 2019, 2:57 p.m. UTC | #1
On 13/04/2019 10:49, Fabrice Fontaine wrote:
> Use pkg-config to find openssl dependencies such as lz or latomic
> 
> Fix static build on sparc v8 (even if there is no autobuilder failures
> yet)
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks.

 Regards,
 Arnout

> ---
>  package/ipsec-tools/ipsec-tools.mk | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
> index 8672272538..7ac6b5cb22 100644
> --- a/package/ipsec-tools/ipsec-tools.mk
> +++ b/package/ipsec-tools/ipsec-tools.mk
> @@ -9,17 +9,14 @@ IPSEC_TOOLS_SOURCE = ipsec-tools-$(IPSEC_TOOLS_VERSION).tar.bz2
>  IPSEC_TOOLS_SITE = http://sourceforge.net/projects/ipsec-tools/files/ipsec-tools/$(IPSEC_TOOLS_VERSION)
>  IPSEC_TOOLS_INSTALL_STAGING = YES
>  IPSEC_TOOLS_MAKE = $(MAKE1)
> -IPSEC_TOOLS_DEPENDENCIES = openssl flex host-flex host-bison
> +IPSEC_TOOLS_DEPENDENCIES = openssl flex host-pkgconf host-flex host-bison
>  # we patch configure.ac
>  IPSEC_TOOLS_AUTORECONF = YES
>  
>  # configure hardcodes -Werror, so override CFLAGS on make invocation
>  IPSEC_TOOLS_MAKE_OPTS = CFLAGS='$(TARGET_CFLAGS)'
>  
> -# openssl uses zlib, so we need to explicitly link with it when static
> -ifeq ($(BR2_STATIC_LIBS),y)
> -IPSEC_TOOLS_CONF_ENV += LIBS=-lz
> -endif
> +IPSEC_TOOLS_CONF_ENV = LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
>  
>  IPSEC_TOOLS_CONF_OPTS = \
>  	  --without-libpam \
>
Peter Korsgaard April 24, 2019, 8 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Use pkg-config to find openssl dependencies such as lz or latomic
 > Fix static build on sparc v8 (even if there is no autobuilder failures
 > yet)

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
index 8672272538..7ac6b5cb22 100644
--- a/package/ipsec-tools/ipsec-tools.mk
+++ b/package/ipsec-tools/ipsec-tools.mk
@@ -9,17 +9,14 @@  IPSEC_TOOLS_SOURCE = ipsec-tools-$(IPSEC_TOOLS_VERSION).tar.bz2
 IPSEC_TOOLS_SITE = http://sourceforge.net/projects/ipsec-tools/files/ipsec-tools/$(IPSEC_TOOLS_VERSION)
 IPSEC_TOOLS_INSTALL_STAGING = YES
 IPSEC_TOOLS_MAKE = $(MAKE1)
-IPSEC_TOOLS_DEPENDENCIES = openssl flex host-flex host-bison
+IPSEC_TOOLS_DEPENDENCIES = openssl flex host-pkgconf host-flex host-bison
 # we patch configure.ac
 IPSEC_TOOLS_AUTORECONF = YES
 
 # configure hardcodes -Werror, so override CFLAGS on make invocation
 IPSEC_TOOLS_MAKE_OPTS = CFLAGS='$(TARGET_CFLAGS)'
 
-# openssl uses zlib, so we need to explicitly link with it when static
-ifeq ($(BR2_STATIC_LIBS),y)
-IPSEC_TOOLS_CONF_ENV += LIBS=-lz
-endif
+IPSEC_TOOLS_CONF_ENV = LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 
 IPSEC_TOOLS_CONF_OPTS = \
 	  --without-libpam \