diff mbox series

[1/1] package/thrift: drop unneeded static openssl workaround

Message ID 20190413083858.12941-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/thrift: drop unneeded static openssl workaround | expand

Commit Message

Fabrice Fontaine April 13, 2019, 8:38 a.m. UTC
thrift uses pkg-config to find openssl dependencies such as lz or
latomic so drop unneeded workaround

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/thrift/thrift.mk | 2 --
 1 file changed, 2 deletions(-)

Comments

Arnout Vandecappelle April 13, 2019, 2:44 p.m. UTC | #1
On 13/04/2019 10:38, Fabrice Fontaine wrote:
> thrift uses pkg-config to find openssl dependencies such as lz or
> latomic so drop unneeded workaround
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks. I've checked, this was already added in the first
commit adding thrift.

 Regards,
 Arnout

> ---
>  package/thrift/thrift.mk | 2 --
>  1 file changed, 2 deletions(-)
> 
> diff --git a/package/thrift/thrift.mk b/package/thrift/thrift.mk
> index 8a284229a1..6014bbfcdd 100644
> --- a/package/thrift/thrift.mk
> +++ b/package/thrift/thrift.mk
> @@ -31,8 +31,6 @@ endif
>  
>  # thrift doesn't use the regular flags BUILD_{STATIC,SHARED}_LIBS
>  ifeq ($(BR2_STATIC_LIBS),y)
> -# openssl uses zlib, so we need to explicitly link with it when static
> -THRIFT_CONF_ENV += LIBS=-lz
>  THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=ON -DWITH_BOOST_STATIC=ON -DWITH_SHARED_LIB=OFF
>  else ifeq ($(BR2_SHARED_LIBS),y)
>  THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=OFF -DWITH_BOOST_STATIC=OFF -DWITH_SHARED_LIB=ON
>
Peter Korsgaard April 24, 2019, 7:59 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > thrift uses pkg-config to find openssl dependencies such as lz or
 > latomic so drop unneeded workaround

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/thrift/thrift.mk b/package/thrift/thrift.mk
index 8a284229a1..6014bbfcdd 100644
--- a/package/thrift/thrift.mk
+++ b/package/thrift/thrift.mk
@@ -31,8 +31,6 @@  endif
 
 # thrift doesn't use the regular flags BUILD_{STATIC,SHARED}_LIBS
 ifeq ($(BR2_STATIC_LIBS),y)
-# openssl uses zlib, so we need to explicitly link with it when static
-THRIFT_CONF_ENV += LIBS=-lz
 THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=ON -DWITH_BOOST_STATIC=ON -DWITH_SHARED_LIB=OFF
 else ifeq ($(BR2_SHARED_LIBS),y)
 THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=OFF -DWITH_BOOST_STATIC=OFF -DWITH_SHARED_LIB=ON