diff mbox series

[1/2] package/msmtp: drop unneeded static openssl workaround

Message ID 20190413083218.6355-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/msmtp: drop unneeded static openssl workaround | expand

Commit Message

Fabrice Fontaine April 13, 2019, 8:32 a.m. UTC
msmtp uses pkg-config to find openssl dependencies such as lz or latomic
so drop unneeded openssl workaround that was added by
https://git.buildroot.net/buildroot/commit/package/msmtp?id=468bbc1538aaea87beaf455a2ad6ea5a255d5f58

I don't know why it was added seven years ago as msmtp already used
pkg-config at this time:
https://github.com/marlam/msmtp-mirror/blob/rel-1-4-27/configure.ac

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/msmtp/msmtp.mk | 4 ----
 1 file changed, 4 deletions(-)

Comments

Arnout Vandecappelle April 13, 2019, 2:43 p.m. UTC | #1
On 13/04/2019 10:32, Fabrice Fontaine wrote:
> msmtp uses pkg-config to find openssl dependencies such as lz or latomic
> so drop unneeded openssl workaround that was added by
> https://git.buildroot.net/buildroot/commit/package/msmtp?id=468bbc1538aaea87beaf455a2ad6ea5a255d5f58
> 
> I don't know why it was added seven years ago as msmtp already used
> pkg-config at this time:
> https://github.com/marlam/msmtp-mirror/blob/rel-1-4-27/configure.ac
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied both to master, thanks.

 Regards,
 Arnout

> ---
>  package/msmtp/msmtp.mk | 4 ----
>  1 file changed, 4 deletions(-)
> 
> diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
> index 079c7c2319..db3d42cd94 100644
> --- a/package/msmtp/msmtp.mk
> +++ b/package/msmtp/msmtp.mk
> @@ -46,10 +46,6 @@ MSMTP_DEPENDENCIES += gnutls
>  else ifeq ($(BR2_PACKAGE_OPENSSL),y)
>  MSMTP_CONF_OPTS += --with-tls=openssl
>  MSMTP_DEPENDENCIES += openssl
> -ifeq ($(BR2_STATIC_LIBS),y)
> -# openssl uses zlib, so we need to explicitly link with it when static
> -MSMTP_CONF_ENV += LIBS=-lz
> -endif
>  else
>  MSMTP_CONF_OPTS += --with-tls=no
>  endif
>
Peter Korsgaard April 14, 2019, 2:56 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > msmtp uses pkg-config to find openssl dependencies such as lz or latomic
 > so drop unneeded openssl workaround that was added by
 > https://git.buildroot.net/buildroot/commit/package/msmtp?id=468bbc1538aaea87beaf455a2ad6ea5a255d5f58

 > I don't know why it was added seven years ago as msmtp already used
 > pkg-config at this time:
 > https://github.com/marlam/msmtp-mirror/blob/rel-1-4-27/configure.ac

I believe it was because we didn't used to pass --static to pkg-config
before

commit 958c9438ccb5e8c8864edf242b6b4ce3b1f058a4
Author: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Date:   Wed Mar 5 12:19:37 2014 +0000

    host-pkgconf: use --static option for static builds
Peter Korsgaard April 24, 2019, 7:59 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > msmtp uses pkg-config to find openssl dependencies such as lz or latomic
 > so drop unneeded openssl workaround that was added by
 > https://git.buildroot.net/buildroot/commit/package/msmtp?id=468bbc1538aaea87beaf455a2ad6ea5a255d5f58

 > I don't know why it was added seven years ago as msmtp already used
 > pkg-config at this time:
 > https://github.com/marlam/msmtp-mirror/blob/rel-1-4-27/configure.ac

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
index 079c7c2319..db3d42cd94 100644
--- a/package/msmtp/msmtp.mk
+++ b/package/msmtp/msmtp.mk
@@ -46,10 +46,6 @@  MSMTP_DEPENDENCIES += gnutls
 else ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MSMTP_CONF_OPTS += --with-tls=openssl
 MSMTP_DEPENDENCIES += openssl
-ifeq ($(BR2_STATIC_LIBS),y)
-# openssl uses zlib, so we need to explicitly link with it when static
-MSMTP_CONF_ENV += LIBS=-lz
-endif
 else
 MSMTP_CONF_OPTS += --with-tls=no
 endif