diff mbox series

[1/1] package/pure-ftpd: fix static build with openssl and latomic

Message ID 20190412212529.23242-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/pure-ftpd: fix static build with openssl and latomic | expand

Commit Message

Fabrice Fontaine April 12, 2019, 9:25 p.m. UTC
Use pkg-config to find openssl dependencies such as lz or latomic

Fixes:
 - http://autobuild.buildroot.org/results/eba8d344446b0db6327c0588c456c14594984f76

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pure-ftpd/pure-ftpd.mk | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Comments

Arnout Vandecappelle April 13, 2019, 2:43 p.m. UTC | #1
On 12/04/2019 23:25, Fabrice Fontaine wrote:
> Use pkg-config to find openssl dependencies such as lz or latomic
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/eba8d344446b0db6327c0588c456c14594984f76
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks.

 Regards,
 Arnout

> ---
>  package/pure-ftpd/pure-ftpd.mk | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/package/pure-ftpd/pure-ftpd.mk b/package/pure-ftpd/pure-ftpd.mk
> index 7012268874..6b85b0c651 100644
> --- a/package/pure-ftpd/pure-ftpd.mk
> +++ b/package/pure-ftpd/pure-ftpd.mk
> @@ -40,10 +40,8 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_OPENSSL),y)
>  PURE_FTPD_CONF_OPTS += --with-tls
> -PURE_FTPD_DEPENDENCIES += openssl
> -ifeq ($(BR2_STATIC_LIBS),y)
> -PURE_FTPD_CONF_ENV += LIBS='-lssl -lcrypto -lz'
> -endif
> +PURE_FTPD_DEPENDENCIES += host-pkgconf openssl
> +PURE_FTPD_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
>  else
>  PURE_FTPD_CONF_OPTS += --without-tls
>  endif
>
Peter Korsgaard April 24, 2019, 7:55 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Use pkg-config to find openssl dependencies such as lz or latomic
 > Fixes:
 >  - http://autobuild.buildroot.org/results/eba8d344446b0db6327c0588c456c14594984f76

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/pure-ftpd/pure-ftpd.mk b/package/pure-ftpd/pure-ftpd.mk
index 7012268874..6b85b0c651 100644
--- a/package/pure-ftpd/pure-ftpd.mk
+++ b/package/pure-ftpd/pure-ftpd.mk
@@ -40,10 +40,8 @@  endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 PURE_FTPD_CONF_OPTS += --with-tls
-PURE_FTPD_DEPENDENCIES += openssl
-ifeq ($(BR2_STATIC_LIBS),y)
-PURE_FTPD_CONF_ENV += LIBS='-lssl -lcrypto -lz'
-endif
+PURE_FTPD_DEPENDENCIES += host-pkgconf openssl
+PURE_FTPD_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 else
 PURE_FTPD_CONF_OPTS += --without-tls
 endif