diff mbox series

[1/1] package/libfreefare: fix static build with latomic

Message ID 20190412171045.18584-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libfreefare: fix static build with latomic | expand

Commit Message

Fabrice Fontaine April 12, 2019, 5:10 p.m. UTC
Use pkg-config to retrieve openssl dependencies such as lz or latomic

Fixes:
 - http://autobuild.buildroot.org/results/9bf69f238a63ea28690f7c0dbb8c30feb0afc5ad

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libfreefare/libfreefare.mk | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

Comments

Arnout Vandecappelle April 13, 2019, 1:59 p.m. UTC | #1
On 12/04/2019 19:10, Fabrice Fontaine wrote:
> Use pkg-config to retrieve openssl dependencies such as lz or latomic
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/9bf69f238a63ea28690f7c0dbb8c30feb0afc5ad
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks.

 Regards,
 Arnout

> ---
>  package/libfreefare/libfreefare.mk | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/package/libfreefare/libfreefare.mk b/package/libfreefare/libfreefare.mk
> index 13e6f2ad5e..16f15b34e4 100644
> --- a/package/libfreefare/libfreefare.mk
> +++ b/package/libfreefare/libfreefare.mk
> @@ -9,13 +9,9 @@ LIBFREEFARE_SOURCE = libfreefare-$(LIBFREEFARE_VERSION).tar.bz2
>  # Do not use the github helper here, the generated tarball is *NOT*
>  # the same as the one uploaded by upstream for the release.
>  LIBFREEFARE_SITE = https://github.com/nfc-tools/libfreefare/releases/download/libfreefare-$(LIBFREEFARE_VERSION)
> -LIBFREEFARE_DEPENDENCIES = libnfc openssl
> +LIBFREEFARE_DEPENDENCIES = host-pkgconf libnfc openssl
>  LIBFREEFARE_LICENSE = LGPL-3.0+ with exception
>  LIBFREEFARE_LICENSE_FILES = COPYING
> -
> -ifeq ($(BR2_STATIC_LIBS),y)
> -# openssl needs zlib even if the libfreefare example itself doesn't
> -LIBFREEFARE_CONF_ENV += LIBS='-lz'
> -endif
> +LIBFREEFARE_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
>  
>  $(eval $(autotools-package))
>
Peter Korsgaard April 24, 2019, 7:54 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Use pkg-config to retrieve openssl dependencies such as lz or latomic
 > Fixes:
 >  - http://autobuild.buildroot.org/results/9bf69f238a63ea28690f7c0dbb8c30feb0afc5ad

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libfreefare/libfreefare.mk b/package/libfreefare/libfreefare.mk
index 13e6f2ad5e..16f15b34e4 100644
--- a/package/libfreefare/libfreefare.mk
+++ b/package/libfreefare/libfreefare.mk
@@ -9,13 +9,9 @@  LIBFREEFARE_SOURCE = libfreefare-$(LIBFREEFARE_VERSION).tar.bz2
 # Do not use the github helper here, the generated tarball is *NOT*
 # the same as the one uploaded by upstream for the release.
 LIBFREEFARE_SITE = https://github.com/nfc-tools/libfreefare/releases/download/libfreefare-$(LIBFREEFARE_VERSION)
-LIBFREEFARE_DEPENDENCIES = libnfc openssl
+LIBFREEFARE_DEPENDENCIES = host-pkgconf libnfc openssl
 LIBFREEFARE_LICENSE = LGPL-3.0+ with exception
 LIBFREEFARE_LICENSE_FILES = COPYING
-
-ifeq ($(BR2_STATIC_LIBS),y)
-# openssl needs zlib even if the libfreefare example itself doesn't
-LIBFREEFARE_CONF_ENV += LIBS='-lz'
-endif
+LIBFREEFARE_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 
 $(eval $(autotools-package))