diff mbox series

package/gettext-tiny: fix build of libintl.a

Message ID 20190331153429.7380-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series package/gettext-tiny: fix build of libintl.a | expand

Commit Message

Yann E. MORIN March 31, 2019, 3:34 p.m. UTC
Since libintl.a can be pulled in during the build of other shared libs,
it must be compiled with -fPIC, which is what gettext-tiny's Makefile
would do.

Since we provide our own CFLAGS, they override those in the Makefile.

Fix that by ensurign that -fPIC is used when building the static
library.

Fixes:
    http://autobuild.buildroot.org/results/a38/a3800fd4ef2536cc2b82d38ea752baa2b227bc64/

Also, since GETTEXT_TINY_OPTS is used only once and contains a single
definition, get rid of it altogether.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vadim Kochan <vadim4j@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/gettext-tiny/gettext-tiny.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni March 31, 2019, 6:56 p.m. UTC | #1
On Sun, 31 Mar 2019 17:34:29 +0200
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Since libintl.a can be pulled in during the build of other shared libs,
> it must be compiled with -fPIC, which is what gettext-tiny's Makefile
> would do.
> 
> Since we provide our own CFLAGS, they override those in the Makefile.
> 
> Fix that by ensurign that -fPIC is used when building the static
> library.
> 
> Fixes:
>     http://autobuild.buildroot.org/results/a38/a3800fd4ef2536cc2b82d38ea752baa2b227bc64/
> 
> Also, since GETTEXT_TINY_OPTS is used only once and contains a single
> definition, get rid of it altogether.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Vadim Kochan <vadim4j@gmail.com>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/gettext-tiny/gettext-tiny.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gettext-tiny/gettext-tiny.mk b/package/gettext-tiny/gettext-tiny.mk
index 3fe2de30b6..c9052d0d7c 100644
--- a/package/gettext-tiny/gettext-tiny.mk
+++ b/package/gettext-tiny/gettext-tiny.mk
@@ -9,7 +9,6 @@  GETTEXT_TINY_SITE = $(call github,sabotage-linux,gettext-tiny,$(GETTEXT_TINY_VER
 GETTEXT_TINY_LICENSE = MIT, GPL-3.0+ (extra gettext)
 GETTEXT_TINY_INSTALL_STAGING = YES
 GETTEXT_TINY_LICENSE_FILES = LICENSE extra/COPYING
-GETTEXT_TINY_OPTS = LIBINTL=NOOP
 
 GETTEXT_TINY_PROVIDES = gettext
 
@@ -56,7 +55,8 @@  endif
 define HOST_GETTEXT_TINY_BUILD_CMDS
 	$(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
 		$(HOST_CONFIGURE_OPTS) \
-		$(GETTEXT_TINY_OPTS)
+		CFLAGS="$(HOST_CFLAGS) -fPIC" \
+		LIBINTL=NOOP
 
 	cp $(@D)/extra/gettextize.in $(@D)/gettextize