diff mbox series

[v2,1/4] package/libfuse: Install udev rules and set permissions

Message ID 20190315133033.5275-2-norbert.lange@andritz.com
State Accepted
Headers show
Series [v2,1/4] package/libfuse: Install udev rules and set permissions | expand

Commit Message

Norbert Lange March 15, 2019, 1:30 p.m. UTC
This fixes some omissions from the installation.

Install the udev rules.

Tell buildroot about the fuse device.

Apply setuid permissions on the fusermount tool.

Signed-off-by: Norbert Lange <norbert.lange@andritz.com>
---
 package/libfuse/libfuse.mk | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 20, 2019, 10:31 p.m. UTC | #1
On 15/03/2019 14:30, Norbert Lange wrote:
> This fixes some omissions from the installation.
> 
> Install the udev rules.
> 
> Tell buildroot about the fuse device.
> 
> Apply setuid permissions on the fusermount tool.
> 
> Signed-off-by: Norbert Lange <norbert.lange@andritz.com>

 Applied to master, thanks.

 Regards,
 Arnout
Peter Korsgaard April 2, 2019, 8:56 p.m. UTC | #2
>>>>> "Norbert" == Norbert Lange <nolange79@gmail.com> writes:

 > This fixes some omissions from the installation.
 > Install the udev rules.

 > Tell buildroot about the fuse device.

 > Apply setuid permissions on the fusermount tool.

 > Signed-off-by: Norbert Lange <norbert.lange@andritz.com>
 > ---
 >  package/libfuse/libfuse.mk | 13 ++++++++++++-
 >  1 file changed, 12 insertions(+), 1 deletion(-)

 > diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
 > index e8a79a3166..84027ebedb 100644
 > --- a/package/libfuse/libfuse.mk
 > +++ b/package/libfuse/libfuse.mk
 > @@ -14,11 +14,22 @@ LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 >  LIBFUSE_CONF_OPTS = \
 >  	--disable-example \
 >  	--enable-lib \
 > -	--enable-util
 > +	--enable-util \
 > +	UDEV_RULES_PATH=/lib/udev/rules.d
 
 >  define LIBFUSE_INSTALL_TARGET_CMDS
 >  	cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
 >  	cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
 > +	mkdir -p $(TARGET_DIR)/lib/udev/rules.d
 > +	cp $(STAGING_DIR)/lib/udev/rules.d/*-fuse.rules $(TARGET_DIR)/lib/udev/rules.d

It would have been nicer to only do this if (e)udev was enabled. I've
sent a patch to do so:

https://patchwork.ozlabs.org/patch/1074963/
Peter Korsgaard April 5, 2019, 8:34 p.m. UTC | #3
>>>>> "Norbert" == Norbert Lange <nolange79@gmail.com> writes:
 >> This fixes some omissions from the installation.
 >> Install the udev rules.

 >> Tell buildroot about the fuse device.

 >> Apply setuid permissions on the fusermount tool.

 >> Signed-off-by: Norbert Lange <norbert.lange@andritz.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
index e8a79a3166..84027ebedb 100644
--- a/package/libfuse/libfuse.mk
+++ b/package/libfuse/libfuse.mk
@@ -14,11 +14,22 @@  LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 LIBFUSE_CONF_OPTS = \
 	--disable-example \
 	--enable-lib \
-	--enable-util
+	--enable-util \
+	UDEV_RULES_PATH=/lib/udev/rules.d
 
 define LIBFUSE_INSTALL_TARGET_CMDS
 	cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
 	cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
+	mkdir -p $(TARGET_DIR)/lib/udev/rules.d
+	cp $(STAGING_DIR)/lib/udev/rules.d/*-fuse.rules $(TARGET_DIR)/lib/udev/rules.d
+endef
+
+define LIBFUSE_DEVICES
+	/dev/fuse  c  666  0  0  10  229  0  0  -
+endef
+
+define LIBFUSE_PERMISSIONS
+	/usr/bin/fusermount f 4755 0 0 - - - - -
 endef
 
 $(eval $(autotools-package))