diff mbox series

libcurl: fix typo in configure option w/o OpenSSL

Message ID 20190220013958.24225-1-tpiepho@impinj.com
State Accepted
Headers show
Series libcurl: fix typo in configure option w/o OpenSSL | expand

Commit Message

Trent Piepho Feb. 20, 2019, 1:40 a.m. UTC
When not using OpenSSL, the correct option to configure is --without-ssl
with two dashes.

Fixes: b8b78e7e6a ("libcurl: Allow selection of TLS package libcurl will use")

Signed-off-by: Trent Piepho <tpiepho@impinj.com>
---
 package/libcurl/libcurl.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle Feb. 20, 2019, 9:34 p.m. UTC | #1
On 20/02/2019 02:40, Trent Piepho wrote:
> When not using OpenSSL, the correct option to configure is --without-ssl
> with two dashes.
> 
> Fixes: b8b78e7e6a ("libcurl: Allow selection of TLS package libcurl will use")
> 
> Signed-off-by: Trent Piepho <tpiepho@impinj.com>

 Applied to master, thanks.

 Peter, this is for 2018.11.x

 Regards,
 Arnout

> ---
>  package/libcurl/libcurl.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
> index 1fae41ea3a..509dbdb54e 100644
> --- a/package/libcurl/libcurl.mk
> +++ b/package/libcurl/libcurl.mk
> @@ -46,7 +46,7 @@ LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)
>  LIBCURL_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr \
>  	--with-ca-path=/etc/ssl/certs
>  else
> -LIBCURL_CONF_OPTS += -without-ssl
> +LIBCURL_CONF_OPTS += --without-ssl
>  endif
>  
>  ifeq ($(BR2_PACKAGE_LIBCURL_GNUTLS),y)
>
Peter Korsgaard Feb. 22, 2019, 12:23 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:

 > On 20/02/2019 02:40, Trent Piepho wrote:
 >> When not using OpenSSL, the correct option to configure is --without-ssl
 >> with two dashes.
 >> 
 >> Fixes: b8b78e7e6a ("libcurl: Allow selection of TLS package libcurl will use")
 >> 
 >> Signed-off-by: Trent Piepho <tpiepho@impinj.com>

 >  Applied to master, thanks.

 >  Peter, this is for 2018.11.x

No it isn't:

git describe --contains b8b78e7e6a
2019.02-rc1~958^2~211

And it hasn't been backported to the 2018.11.x branch.
Arnout Vandecappelle Feb. 22, 2019, 12:27 p.m. UTC | #3
On 22/02/2019 13:23, Peter Korsgaard wrote:
>>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:
> 
>  > On 20/02/2019 02:40, Trent Piepho wrote:
>  >> When not using OpenSSL, the correct option to configure is --without-ssl
>  >> with two dashes.
>  >> 
>  >> Fixes: b8b78e7e6a ("libcurl: Allow selection of TLS package libcurl will use")
>  >> 
>  >> Signed-off-by: Trent Piepho <tpiepho@impinj.com>
> 
>  >  Applied to master, thanks.
> 
>  >  Peter, this is for 2018.11.x
> 
> No it isn't:
> 
> git describe --contains b8b78e7e6a
> 2019.02-rc1~958^2~211

 I thought I hade done exactly that... I guess I was doing too many things at
the same time :-)

 Regards,
 Arnout

> 
> And it hasn't been backported to the 2018.11.x branch.
>
diff mbox series

Patch

diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 1fae41ea3a..509dbdb54e 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -46,7 +46,7 @@  LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)
 LIBCURL_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr \
 	--with-ca-path=/etc/ssl/certs
 else
-LIBCURL_CONF_OPTS += -without-ssl
+LIBCURL_CONF_OPTS += --without-ssl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL_GNUTLS),y)