diff mbox series

[01/16] package/gnuradio: remove qtgui option

Message ID 20190206141058.24155-1-peter@korsgaard.com
State Accepted
Headers show
Series [01/16] package/gnuradio: remove qtgui option | expand

Commit Message

Peter Korsgaard Feb. 6, 2019, 2:10 p.m. UTC
The gr-qtgui option uses python-pyqt/Qt4, which we are about to remove, so
remove the option.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Config.in.legacy             |  6 ++++++
 package/gnuradio/Config.in   | 10 ----------
 package/gnuradio/gnuradio.mk | 10 ++--------
 3 files changed, 8 insertions(+), 18 deletions(-)

Comments

Gwenhael Goavec-Merou Feb. 6, 2019, 2:39 p.m. UTC | #1
Peter, all.
I'm not really happy by removing QT support. It's true, current version use QT4
and python2.7 but github master uses QT5 and python3. Instead of removing this
option (with the need to re-add soon) it's maybe a better idea to use a more
recent hash (or backporting debian patch) to switch to QT5.
I don't know which version is better;

Gwen

 On Wed,  6 Feb 2019 15:10:43 +0100
Peter Korsgaard <peter@korsgaard.com> wrote:

> The gr-qtgui option uses python-pyqt/Qt4, which we are about to remove, so
> remove the option.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  Config.in.legacy             |  6 ++++++
>  package/gnuradio/Config.in   | 10 ----------
>  package/gnuradio/gnuradio.mk | 10 ++--------
>  3 files changed, 8 insertions(+), 18 deletions(-)
> 
> diff --git a/Config.in.legacy b/Config.in.legacy
> index be2f722b05..c84a9239a7 100644
> --- a/Config.in.legacy
> +++ b/Config.in.legacy
> @@ -146,6 +146,12 @@ endif
>  
>  comment "Legacy options removed in 2019.02"
>  
> +config BR2_PACKAGE_GNURADIO_QTGUI
> +	bool "gnuradio gr-qtgui option removed"
> +	select BR2_LEGACY
> +	help
> +	  The gr-qtgui option was removed.
> +
>  config BR2_PACKAGE_LUACRYPTO
>  	bool "luacrypto package removed"
>  	select BR2_LEGACY
> diff --git a/package/gnuradio/Config.in b/package/gnuradio/Config.in
> index 533a49c81e..3fdaea850e 100644
> --- a/package/gnuradio/Config.in
> +++ b/package/gnuradio/Config.in
> @@ -116,16 +116,6 @@ config BR2_PACKAGE_GNURADIO_PAGER
>  	help
>  	  FLEX pager decoder implementation blocks
>  
> -config BR2_PACKAGE_GNURADIO_QTGUI
> -	bool "gr-qtgui"
> -	depends on BR2_PACKAGE_PYTHON_PYQT
> -	depends on BR2_PACKAGE_QWT
> -	depends on BR2_PACKAGE_QT_STL
> -	select BR2_PACKAGE_GNURADIO_FFT
> -	select BR2_PACKAGE_GNURADIO_FILTER
> -	help
> -	  GNU Radio Qt scopes
> -
>  config BR2_PACKAGE_GNURADIO_TRELLIS
>  	bool "gr-trellis support"
>  	select BR2_PACKAGE_GNURADIO_DIGITAL
> diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
> index 564ad8b2a4..d6d07f6566 100644
> --- a/package/gnuradio/gnuradio.mk
> +++ b/package/gnuradio/gnuradio.mk
> @@ -25,7 +25,8 @@ endif
>  GNURADIO_CONF_OPTS = \
>  	-DENABLE_DEFAULT=OFF \
>  	-DENABLE_VOLK=ON \
> -	-DENABLE_GNURADIO_RUNTIME=ON
> +	-DENABLE_GNURADIO_RUNTIME=ON \
> +	-DENABLE_GR_QTGUI=OFF
>  
>  # For third-party blocks, the gnuradio libraries are mandatory at
>  # compile time.
> @@ -126,13 +127,6 @@ else
>  GNURADIO_CONF_OPTS += -DENABLE_PAGER=OFF
>  endif
>  
> -ifeq ($(BR2_PACKAGE_GNURADIO_QTGUI),y)
> -GNURADIO_DEPENDENCIES += python-pyqt qwt
> -GNURADIO_CONF_OPTS += -DENABLE_GR_QTGUI=ON
> -else
> -GNURADIO_CONF_OPTS += -DENABLE_GR_QTGUI=OFF
> -endif
> -
>  ifeq ($(BR2_PACKAGE_GNURADIO_TRELLIS),y)
>  GNURADIO_CONF_OPTS += -DENABLE_GR_TRELLIS=ON
>  else
> -- 
> 2.11.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Feb. 6, 2019, 2:52 p.m. UTC | #2
Hello,

On Wed, 6 Feb 2019 15:39:50 +0100
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> I'm not really happy by removing QT support. It's true, current version use QT4
> and python2.7 but github master uses QT5 and python3. Instead of removing this
> option (with the need to re-add soon) it's maybe a better idea to use a more
> recent hash (or backporting debian patch) to switch to QT5.
> I don't know which version is better;

We have marked Qt4 obsolete a year ago, it's no longer maintained, and
it doesn't build with OpenSSL 1.1, it's really time to remove it.

We will happily take a follow-up patch that re-enables Qt support in
gnuradio once the gnuradio package in Buildroot uses a sufficiently
recent version of it that has Qt5 support.

Would that work for you ?

Thanks,

Thomas
Arnout Vandecappelle Feb. 6, 2019, 2:54 p.m. UTC | #3
On 06/02/2019 15:52, Thomas Petazzoni wrote:
> Hello,
> 
> On Wed, 6 Feb 2019 15:39:50 +0100
> Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:
> 
>> I'm not really happy by removing QT support. It's true, current version use QT4
>> and python2.7 but github master uses QT5 and python3. Instead of removing this
>> option (with the need to re-add soon) it's maybe a better idea to use a more
>> recent hash (or backporting debian patch) to switch to QT5.
>> I don't know which version is better;
> 
> We have marked Qt4 obsolete a year ago, it's no longer maintained, and
> it doesn't build with OpenSSL 1.1, it's really time to remove it.
> 
> We will happily take a follow-up patch that re-enables Qt support in
> gnuradio once the gnuradio package in Buildroot uses a sufficiently
> recent version of it that has Qt5 support.

 Also note that the qt5 integration in gnuradio.mk will anyway need to be very
different from the current qt4 integration, so it's OK to remove it first and
add later.

 BTW, series applied to master, thanks.


 Regards,
 Arnout
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index be2f722b05..c84a9239a7 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,12 @@  endif
 
 comment "Legacy options removed in 2019.02"
 
+config BR2_PACKAGE_GNURADIO_QTGUI
+	bool "gnuradio gr-qtgui option removed"
+	select BR2_LEGACY
+	help
+	  The gr-qtgui option was removed.
+
 config BR2_PACKAGE_LUACRYPTO
 	bool "luacrypto package removed"
 	select BR2_LEGACY
diff --git a/package/gnuradio/Config.in b/package/gnuradio/Config.in
index 533a49c81e..3fdaea850e 100644
--- a/package/gnuradio/Config.in
+++ b/package/gnuradio/Config.in
@@ -116,16 +116,6 @@  config BR2_PACKAGE_GNURADIO_PAGER
 	help
 	  FLEX pager decoder implementation blocks
 
-config BR2_PACKAGE_GNURADIO_QTGUI
-	bool "gr-qtgui"
-	depends on BR2_PACKAGE_PYTHON_PYQT
-	depends on BR2_PACKAGE_QWT
-	depends on BR2_PACKAGE_QT_STL
-	select BR2_PACKAGE_GNURADIO_FFT
-	select BR2_PACKAGE_GNURADIO_FILTER
-	help
-	  GNU Radio Qt scopes
-
 config BR2_PACKAGE_GNURADIO_TRELLIS
 	bool "gr-trellis support"
 	select BR2_PACKAGE_GNURADIO_DIGITAL
diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index 564ad8b2a4..d6d07f6566 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -25,7 +25,8 @@  endif
 GNURADIO_CONF_OPTS = \
 	-DENABLE_DEFAULT=OFF \
 	-DENABLE_VOLK=ON \
-	-DENABLE_GNURADIO_RUNTIME=ON
+	-DENABLE_GNURADIO_RUNTIME=ON \
+	-DENABLE_GR_QTGUI=OFF
 
 # For third-party blocks, the gnuradio libraries are mandatory at
 # compile time.
@@ -126,13 +127,6 @@  else
 GNURADIO_CONF_OPTS += -DENABLE_PAGER=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_GNURADIO_QTGUI),y)
-GNURADIO_DEPENDENCIES += python-pyqt qwt
-GNURADIO_CONF_OPTS += -DENABLE_GR_QTGUI=ON
-else
-GNURADIO_CONF_OPTS += -DENABLE_GR_QTGUI=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_GNURADIO_TRELLIS),y)
 GNURADIO_CONF_OPTS += -DENABLE_GR_TRELLIS=ON
 else