diff mbox series

[2/2] package/python-pyzmq: Enable draft APIs when supported by ZeroMQ

Message ID 20190205102814.11288-2-lionel@svkt.org
State Accepted
Headers show
Series [1/2] package/zeromq: Allow building with draft APIs enabled | expand

Commit Message

Lionel Flandrin Feb. 5, 2019, 10:28 a.m. UTC
This doesn't introduce a new config flag, instead it just automatically enables
draft support if it's configured in the zeromq package itself.

Signed-off-by: Lionel Flandrin <lionel@svkt.org>
---
 package/python-pyzmq/python-pyzmq.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Feb. 6, 2019, 4:19 p.m. UTC | #1
On Tue,  5 Feb 2019 11:28:14 +0100
Lionel Flandrin <lionel@svkt.org> wrote:

> This doesn't introduce a new config flag, instead it just automatically enables
> draft support if it's configured in the zeromq package itself.
> 
> Signed-off-by: Lionel Flandrin <lionel@svkt.org>
> ---
>  package/python-pyzmq/python-pyzmq.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-pyzmq/python-pyzmq.mk b/package/python-pyzmq/python-pyzmq.mk
index 1f7cb5d613..b977cca927 100644
--- a/package/python-pyzmq/python-pyzmq.mk
+++ b/package/python-pyzmq/python-pyzmq.mk
@@ -22,4 +22,8 @@  endef
 
 PYTHON_PYZMQ_POST_PATCH_HOOKS += PYTHON_PYZMQ_PATCH_ZEROMQ_VERSION
 
+ifeq ($(BR2_PACKAGE_ZEROMQ_DRAFTS),y)
+PYTHON_PYZMQ_BUILD_OPTS += --enable-drafts
+endif
+
 $(eval $(python-package))