diff mbox series

[2/2] libpcap: add support for bluez5_utils

Message ID 20190129223355.30600-2-fontaine.fabrice@gmail.com
State Accepted
Commit 4c8760bdc501f44dcf77a8ee40349a4387e517ac
Headers show
Series [1/2] libpcap: remove unrecognized canusb option | expand

Commit Message

Fabrice Fontaine Jan. 29, 2019, 10:33 p.m. UTC
bluez5_utils support has been added since version 1.8.0 and
https://github.com/the-tcpdump-group/libpcap/commit/b3776f3d50df9de9fcf702bd21a3ecb2539ffef4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libpcap/libpcap.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Baruch Siach Jan. 30, 2019, 6:29 a.m. UTC | #1
On Tue, Jan 29, 2019 at 11:33:55PM +0100, Fabrice Fontaine wrote:
> bluez5_utils support has been added since version 1.8.0 and
> https://github.com/the-tcpdump-group/libpcap/commit/b3776f3d50df9de9fcf702bd21a3ecb2539ffef4
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Baruch Siach <baruch@tkos.co.il>

baruch

> ---
>  package/libpcap/libpcap.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
> index daa369f66c..8cc444e7af 100644
> --- a/package/libpcap/libpcap.mk
> +++ b/package/libpcap/libpcap.mk
> @@ -24,9 +24,10 @@ define LIBPCAP_CONFIG_REMOVE_RPATH
>  endef
>  LIBPCAP_POST_BUILD_HOOKS = LIBPCAP_CONFIG_REMOVE_RPATH
>  
> -# On purpose, not compatible with bluez5
>  ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
>  LIBPCAP_DEPENDENCIES += bluez_utils
> +else ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
> +LIBPCAP_DEPENDENCIES += bluez5_utils
>  else
>  LIBPCAP_CONF_OPTS += --disable-bluetooth
>  endif
> -- 
> 2.14.1
>
Peter Korsgaard Feb. 2, 2019, 9:56 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > bluez5_utils support has been added since version 1.8.0 and
 > https://github.com/the-tcpdump-group/libpcap/commit/b3776f3d50df9de9fcf702bd21a3ecb2539ffef4

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index daa369f66c..8cc444e7af 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -24,9 +24,10 @@  define LIBPCAP_CONFIG_REMOVE_RPATH
 endef
 LIBPCAP_POST_BUILD_HOOKS = LIBPCAP_CONFIG_REMOVE_RPATH
 
-# On purpose, not compatible with bluez5
 ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
 LIBPCAP_DEPENDENCIES += bluez_utils
+else ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
+LIBPCAP_DEPENDENCIES += bluez5_utils
 else
 LIBPCAP_CONF_OPTS += --disable-bluetooth
 endif