diff mbox series

[2/2] leveldb: disable parallel build

Message ID 20190129193929.27076-2-fontaine.fabrice@gmail.com
State Accepted
Commit fb22931bcfa66e2b1c8788245876ad7fed134477
Headers show
Series [1/2] Revert "leveldb: fix parallel build" | expand

Commit Message

Fabrice Fontaine Jan. 29, 2019, 7:39 p.m. UTC
Commit abba4e701246f69bc22ca9045e9932abfe9228e9 did not succeed in
fixing all parallel build failures because sometimes $(SHARED_OUTDIR) is
created but not $(SHARED_OUTDIR)/db so instead of fixing this mess,
revert the patch and disable parallel build as upstream switched to
cmake

Fixes:
 - http://autobuild.buildroot.org/results/9c33692aa130a20b0f8e868156e49990e862d6ee

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/leveldb/leveldb.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard Jan. 30, 2019, 7:38 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Commit abba4e701246f69bc22ca9045e9932abfe9228e9 did not succeed in
 > fixing all parallel build failures because sometimes $(SHARED_OUTDIR) is
 > created but not $(SHARED_OUTDIR)/db so instead of fixing this mess,
 > revert the patch and disable parallel build as upstream switched to
 > cmake

 > Fixes:
 >  - http://autobuild.buildroot.org/results/9c33692aa130a20b0f8e868156e49990e862d6ee

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 30, 2019, 9:43 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Commit abba4e701246f69bc22ca9045e9932abfe9228e9 did not succeed in
 > fixing all parallel build failures because sometimes $(SHARED_OUTDIR) is
 > created but not $(SHARED_OUTDIR)/db so instead of fixing this mess,
 > revert the patch and disable parallel build as upstream switched to
 > cmake

 > Fixes:
 >  - http://autobuild.buildroot.org/results/9c33692aa130a20b0f8e868156e49990e862d6ee

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2018.02.x and 2018.11.x, thanks.
diff mbox series

Patch

diff --git a/package/leveldb/leveldb.mk b/package/leveldb/leveldb.mk
index 54942a0f27..af9e879828 100644
--- a/package/leveldb/leveldb.mk
+++ b/package/leveldb/leveldb.mk
@@ -17,18 +17,18 @@  LEVELDB_MAKE_ARGS += SHARED_LIBS= SHARED_PROGRAMS=
 endif
 
 define LEVELDB_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) \
+	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE1) \
 		$(LEVELDB_MAKE_ARGS) -C $(@D)
 endef
 
 define LEVELDB_INSTALL_STAGING_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) \
+	$(TARGET_MAKE_ENV) $(MAKE1) \
 		INSTALL_ROOT=$(STAGING_DIR) INSTALL_PREFIX=/usr \
 		$(LEVELDB_MAKE_ARGS) -C $(@D) install
 endef
 
 define LEVELDB_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) \
+	$(TARGET_MAKE_ENV) $(MAKE1) \
 		INSTALL_ROOT=$(TARGET_DIR) INSTALL_PREFIX=/usr \
 		$(LEVELDB_MAKE_ARGS) -C $(@D) install
 endef