diff mbox series

[1/1] msmtp: fix configure with openssl/gnutls

Message ID 20181229012134.2037-1-bluemrp9@gmail.com
State Accepted
Headers show
Series [1/1] msmtp: fix configure with openssl/gnutls | expand

Commit Message

Ryan Coe Dec. 29, 2018, 1:21 a.m. UTC
Msmtp no longer uses openssl as default [1]. The configure options have
changed from --use-ssl to --use-tls. As a note, openssl usage is discouraged
and may be removed in the future.

[1] https://marlam.de/msmtp/news/openssl-discouraged/

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
---
 package/msmtp/msmtp.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Dec. 29, 2018, 9:40 a.m. UTC | #1
Hello Ryan,

Thanks for this patch.

On Fri, 28 Dec 2018 17:21:34 -0800, Ryan Coe wrote:
> Msmtp no longer uses openssl as default [1]. The configure options have
> changed from --use-ssl to --use-tls. As a note, openssl usage is discouraged
> and may be removed in the future.

Then perhaps, as a separate patch, you could invert the gnutls/openssl
preference, so that if both are available, gnutls is used in favor of
openssl ?

Best regards,

Thomas
Thomas Petazzoni Dec. 30, 2018, 3:32 p.m. UTC | #2
Hello,

On Fri, 28 Dec 2018 17:21:34 -0800, Ryan Coe wrote:
> Msmtp no longer uses openssl as default [1]. The configure options have
> changed from --use-ssl to --use-tls. As a note, openssl usage is discouraged
> and may be removed in the future.
> 
> [1] https://marlam.de/msmtp/news/openssl-discouraged/
> 
> Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
> ---
>  package/msmtp/msmtp.mk | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

I've reworked the commit log to indicate since when msmtp has changed
this configure option: it is quite important to know for our stable/LTS
branches. Also, I've dropped the indication that openssl is no longer
the default: it is unrelated to this specific patch.

Applied with those changes. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
index a495072abf..a26de92ef9 100644
--- a/package/msmtp/msmtp.mk
+++ b/package/msmtp/msmtp.mk
@@ -41,17 +41,17 @@  MSMTP_CONF_OPTS += --without-libsecret
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MSMTP_CONF_OPTS += --with-ssl=openssl
+MSMTP_CONF_OPTS += --with-tls=openssl
 MSMTP_DEPENDENCIES += openssl
 ifeq ($(BR2_STATIC_LIBS),y)
 # openssl uses zlib, so we need to explicitly link with it when static
 MSMTP_CONF_ENV += LIBS=-lz
 endif
 else ifeq ($(BR2_PACKAGE_GNUTLS),y)
-MSMTP_CONF_OPTS += --with-ssl=gnutls
+MSMTP_CONF_OPTS += --with-tls=gnutls
 MSMTP_DEPENDENCIES += gnutls
 else
-MSMTP_CONF_OPTS += --with-ssl=no
+MSMTP_CONF_OPTS += --with-tls=no
 endif
 
 $(eval $(autotools-package))