diff mbox series

[1/1] package/php: fix building pcre extension

Message ID 20181228165634.63387-1-aduskett@gmail.com
State Accepted
Headers show
Series [1/1] package/php: fix building pcre extension | expand

Commit Message

Adam Duskett Dec. 28, 2018, 4:56 p.m. UTC
From: Adam Duskett <Aduskett@gmail.com>

The configure option "--with-pcre-regex=$(STAGING_DIR)/usr" is broken.
PHP will  prepend $(STAGING_DIR)/usr to the paths, which will cause a
failure because it won't be able to find pcre, and will then fallback to
searching for pcre2, which won't be installed.

Removing "=$(STAGING_DIR)/usr" from --with-pcre-regex fixes the issue.

Fixes:
  http://autobuild.buildroot.net/results/586/586f56e8fcf2d2bbbd3bdf69b1c3befff7ce8bbf
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
 package/php/php.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mark Corbin Jan. 4, 2019, 9:04 p.m. UTC | #1
Hello Adam

On 28/12/2018 16:56, aduskett@gmail.com wrote:
> From: Adam Duskett <Aduskett@gmail.com>
>
> The configure option "--with-pcre-regex=$(STAGING_DIR)/usr" is broken.
> PHP will  prepend $(STAGING_DIR)/usr to the paths, which will cause a
> failure because it won't be able to find pcre, and will then fallback to
> searching for pcre2, which won't be installed.
>
> Removing "=$(STAGING_DIR)/usr" from --with-pcre-regex fixes the issue.
>
> Fixes:
>   http://autobuild.buildroot.net/results/586/586f56e8fcf2d2bbbd3bdf69b1c3befff7ce8bbf
> Signed-off-by: Adam Duskett <Aduskett@gmail.com>
> ---
>  package/php/php.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/php/php.mk b/package/php/php.mk
> index fd428e192a..7d7d78353b 100644
> --- a/package/php/php.mk
> +++ b/package/php/php.mk
> @@ -244,7 +244,7 @@ PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
>  
>  ### Use external PCRE if it's available
>  ifeq ($(BR2_PACKAGE_PCRE),y)
> -PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
> +PHP_CONF_OPTS += --with-pcre-regex
>  PHP_DEPENDENCIES += pcre
>  else
>  # The bundled pcre library is not configurable through ./configure options,

I can confirm that this fixes
http://autobuild.buildroot.net/results/586/586f56e8fcf2d2bbbd3bdf69b1c3befff7ce8bbf
on my build system.

Tested-by: Mark Corbin <mark.corbin@embecosm.com>
Arnout Vandecappelle Jan. 10, 2019, 10:06 p.m. UTC | #2
On 28/12/2018 17:56, aduskett@gmail.com wrote:
> From: Adam Duskett <Aduskett@gmail.com>
> 
> The configure option "--with-pcre-regex=$(STAGING_DIR)/usr" is broken.
> PHP will  prepend $(STAGING_DIR)/usr to the paths, which will cause a
> failure because it won't be able to find pcre, and will then fallback to
> searching for pcre2, which won't be installed.
> 
> Removing "=$(STAGING_DIR)/usr" from --with-pcre-regex fixes the issue.
> 
> Fixes:
>   http://autobuild.buildroot.net/results/586/586f56e8fcf2d2bbbd3bdf69b1c3befff7ce8bbf
> Signed-off-by: Adam Duskett <Aduskett@gmail.com>

 Applied to master, thanks.

 Care to add yourself as a developer for php?

 Regards,
 Arnout

> ---
>  package/php/php.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/php/php.mk b/package/php/php.mk
> index fd428e192a..7d7d78353b 100644
> --- a/package/php/php.mk
> +++ b/package/php/php.mk
> @@ -244,7 +244,7 @@ PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
>  
>  ### Use external PCRE if it's available
>  ifeq ($(BR2_PACKAGE_PCRE),y)
> -PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
> +PHP_CONF_OPTS += --with-pcre-regex
>  PHP_DEPENDENCIES += pcre
>  else
>  # The bundled pcre library is not configurable through ./configure options,
>
diff mbox series

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index fd428e192a..7d7d78353b 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -244,7 +244,7 @@  PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
 
 ### Use external PCRE if it's available
 ifeq ($(BR2_PACKAGE_PCRE),y)
-PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
+PHP_CONF_OPTS += --with-pcre-regex
 PHP_DEPENDENCIES += pcre
 else
 # The bundled pcre library is not configurable through ./configure options,