diff mbox series

[v2,2/4] skeleton: use BR2_SYSTEM_DEFAULT_PATH as default PATH

Message ID 20181219210455.14754-3-mmayer@broadcom.com
State Superseded
Headers show
Series Allow customization of system default PATH | expand

Commit Message

Markus Mayer Dec. 19, 2018, 9:04 p.m. UTC
We substitute the path specified in system/skeleton/etc/profile with
the path specified in the configuration variable
$(BR2_SYSTEM_DEFAULT_PATH).

$(BR2_SYSTEM_DEFAULT_PATH) is a Kconfig string. So it is already
quoted, which is exactly what we want.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
---
 package/skeleton-init-common/skeleton-init-common.mk | 1 +
 system/skeleton/etc/profile                          | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Dec. 19, 2018, 9:34 p.m. UTC | #1
Markus, All,

On 2018-12-19 13:04 -0800, Markus Mayer spake thusly:
> We substitute the path specified in system/skeleton/etc/profile with
> the path specified in the configuration variable
> $(BR2_SYSTEM_DEFAULT_PATH).
> 
> $(BR2_SYSTEM_DEFAULT_PATH) is a Kconfig string. So it is already
> quoted, which is exactly what we want.
> 
> Signed-off-by: Markus Mayer <mmayer@broadcom.com>
> ---
>  package/skeleton-init-common/skeleton-init-common.mk | 1 +
>  system/skeleton/etc/profile                          | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/skeleton-init-common/skeleton-init-common.mk b/package/skeleton-init-common/skeleton-init-common.mk
> index e8a052205268..866273bbd7ee 100644
> --- a/package/skeleton-init-common/skeleton-init-common.mk
> +++ b/package/skeleton-init-common/skeleton-init-common.mk
> @@ -22,6 +22,7 @@ define SKELETON_INIT_COMMON_INSTALL_TARGET_CMDS
>  	$(call SYSTEM_LIB_SYMLINK,$(TARGET_DIR))
>  	$(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
>  		$(TARGET_DIR_WARNING_FILE)
> +	$(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile

I think we should keep the warning file the last command executed.

Otherwise:

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

>  endef
>  
>  # We don't care much about what goes in staging, as long as it is
> diff --git a/system/skeleton/etc/profile b/system/skeleton/etc/profile
> index 1255d23ff40d..db29e44920e8 100644
> --- a/system/skeleton/etc/profile
> +++ b/system/skeleton/etc/profile
> @@ -1,4 +1,4 @@
> -export PATH=/bin:/sbin:/usr/bin:/usr/sbin
> +export PATH=@PATH@
>  
>  if [ "$PS1" ]; then
>  	if [ "`id -u`" -eq 0 ]; then
> -- 
> 2.17.1
>
Markus Mayer Dec. 19, 2018, 11:24 p.m. UTC | #2
Hi Yann,

On Wed, 19 Dec 2018 at 13:34, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>
> Markus, All,
>
> > diff --git a/package/skeleton-init-common/skeleton-init-common.mk b/package/skeleton-init-common/skeleton-init-common.mk
> > index e8a052205268..866273bbd7ee 100644
> > --- a/package/skeleton-init-common/skeleton-init-common.mk
> > +++ b/package/skeleton-init-common/skeleton-init-common.mk
> > @@ -22,6 +22,7 @@ define SKELETON_INIT_COMMON_INSTALL_TARGET_CMDS
> >       $(call SYSTEM_LIB_SYMLINK,$(TARGET_DIR))
> >       $(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
> >               $(TARGET_DIR_WARNING_FILE)
> > +     $(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile
>
> I think we should keep the warning file the last command executed.

I am not sure I am following. I am not doing anything to target-dir-warning.txt.

> Otherwise:
>
> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
>
> Regards,
> Yann E. MORIN.

Thanks,
-Markus
Yann E. MORIN Dec. 20, 2018, 4:04 p.m. UTC | #3
Markus, All,

On 2018-12-19 15:24 -0800, Markus Mayer spake thusly:
> On Wed, 19 Dec 2018 at 13:34, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > > diff --git a/package/skeleton-init-common/skeleton-init-common.mk b/package/skeleton-init-common/skeleton-init-common.mk
> > > index e8a052205268..866273bbd7ee 100644
> > > --- a/package/skeleton-init-common/skeleton-init-common.mk
> > > +++ b/package/skeleton-init-common/skeleton-init-common.mk
> > > @@ -22,6 +22,7 @@ define SKELETON_INIT_COMMON_INSTALL_TARGET_CMDS
> > >       $(call SYSTEM_LIB_SYMLINK,$(TARGET_DIR))
> > >       $(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
> > >               $(TARGET_DIR_WARNING_FILE)
> > > +     $(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile
> > I think we should keep the warning file the last command executed.
> I am not sure I am following. I am not doing anything to target-dir-warning.txt.

Just put your sed command before the warning file:

    $(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile
    $(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
            $(TARGET_DIR_WARNING_FILE)

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/skeleton-init-common/skeleton-init-common.mk b/package/skeleton-init-common/skeleton-init-common.mk
index e8a052205268..866273bbd7ee 100644
--- a/package/skeleton-init-common/skeleton-init-common.mk
+++ b/package/skeleton-init-common/skeleton-init-common.mk
@@ -22,6 +22,7 @@  define SKELETON_INIT_COMMON_INSTALL_TARGET_CMDS
 	$(call SYSTEM_LIB_SYMLINK,$(TARGET_DIR))
 	$(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
 		$(TARGET_DIR_WARNING_FILE)
+	$(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile
 endef
 
 # We don't care much about what goes in staging, as long as it is
diff --git a/system/skeleton/etc/profile b/system/skeleton/etc/profile
index 1255d23ff40d..db29e44920e8 100644
--- a/system/skeleton/etc/profile
+++ b/system/skeleton/etc/profile
@@ -1,4 +1,4 @@ 
-export PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH=@PATH@
 
 if [ "$PS1" ]; then
 	if [ "`id -u`" -eq 0 ]; then