diff mbox series

[1/1] cryptsetup: fix systemd build wih pkgconf 1.5.3

Message ID 20181215115027.32307-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] cryptsetup: fix systemd build wih pkgconf 1.5.3 | expand

Commit Message

Fabrice Fontaine Dec. 15, 2018, 11:50 a.m. UTC
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

cryptsetup uses the tmpfilesdir variable from systemd.pc to decide where
to install things. Since DESTDIR is prepended to the install
destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the tmpfilesdir to use
explicitly instead of relying on systemd.pc.

Fixes:
 - http://autobuild.buildroot.org/results/930dcd3e408106e01fa519058cd2677c867b73dd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/cryptsetup/cryptsetup.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/cryptsetup/cryptsetup.mk b/package/cryptsetup/cryptsetup.mk
index dd1ef2e9e0..5987038af9 100644
--- a/package/cryptsetup/cryptsetup.mk
+++ b/package/cryptsetup/cryptsetup.mk
@@ -14,7 +14,7 @@  CRYPTSETUP_LICENSE = GPL-2.0+ (programs), LGPL-2.1+ (library)
 CRYPTSETUP_LICENSE_FILES = COPYING COPYING.LGPL
 CRYPTSETUP_INSTALL_STAGING = YES
 CRYPTSETUP_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)"
-CRYPTSETUP_CONF_OPTS += --enable-blkid
+CRYPTSETUP_CONF_OPTS += --enable-blkid --with-tmpfilesdir=/usr/lib/tmpfiles.d
 
 # cryptsetup uses libgcrypt by default, but can be configured to use OpenSSL
 # or kernel crypto modules instead