diff mbox series

[next,1/2] package/pkg-luarocks: drop flock at installation time

Message ID 20181119103227.24726-2-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series Adjust Luarocks support to per-package folder | expand

Commit Message

Thomas Petazzoni Nov. 19, 2018, 10:32 a.m. UTC
In commit 22b327fc743b48a33aec0a9190bd67118641b294 ("pkg-luarocks: fix
top-level parallel makefile support"), a flock on $(TARGET_DIR) was
added to ensure that two Luarocks packages are not installed at the
same time.

However, to support top-level parallel build, we have now clearly
decided that per-package folders is a requirement. Therefore,
TARGET_DIR is anyway going to be different for each package, making
this flock unnecessary.

Trying to use top-level parallel build without per-package folder is
simply not supported, so this commit drops the unnecessary flock.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/pkg-luarocks.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Francois Perrad Nov. 19, 2018, 8:28 p.m. UTC | #1
Le lun. 19 nov. 2018 à 11:32, Thomas Petazzoni <thomas.petazzoni@bootlin.com>
a écrit :

> In commit 22b327fc743b48a33aec0a9190bd67118641b294 ("pkg-luarocks: fix
> top-level parallel makefile support"), a flock on $(TARGET_DIR) was
> added to ensure that two Luarocks packages are not installed at the
> same time.
>
> However, to support top-level parallel build, we have now clearly
> decided that per-package folders is a requirement. Therefore,
> TARGET_DIR is anyway going to be different for each package, making
> this flock unnecessary.
>
> Trying to use top-level parallel build without per-package folder is
> simply not supported, so this commit drops the unnecessary flock.
>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
>

Acked-by: Francois Perrad <francois.perrad@gadz.org>

---
>  package/pkg-luarocks.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
> index 29c5e66cd1..f0985433b7 100644
> --- a/package/pkg-luarocks.mk
> +++ b/package/pkg-luarocks.mk
> @@ -63,7 +63,7 @@ endif
>  #
>  ifndef $(2)_INSTALL_TARGET_CMDS
>  define $(2)_INSTALL_TARGET_CMDS
> -       cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) flock $$(TARGET_DIR) \
> +       cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) \
>                 $$(LUAROCKS_RUN_CMD) make --keep $$($(2)_ROCKSPEC)
> $$($(2)_BUILD_OPTS)
>  endef
>  endif
> --
> 2.19.1
>
>
<div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr">Le lun. 19 nov. 2018 à 11:32, Thomas Petazzoni &lt;<a href="mailto:thomas.petazzoni@bootlin.com">thomas.petazzoni@bootlin.com</a>&gt; a écrit :<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">In commit 22b327fc743b48a33aec0a9190bd67118641b294 (&quot;pkg-luarocks: fix<br>
top-level parallel makefile support&quot;), a flock on $(TARGET_DIR) was<br>
added to ensure that two Luarocks packages are not installed at the<br>
same time.<br>
<br>
However, to support top-level parallel build, we have now clearly<br>
decided that per-package folders is a requirement. Therefore,<br>
TARGET_DIR is anyway going to be different for each package, making<br>
this flock unnecessary.<br>
<br>
Trying to use top-level parallel build without per-package folder is<br>
simply not supported, so this commit drops the unnecessary flock.<br>
<br>
Signed-off-by: Thomas Petazzoni &lt;<a href="mailto:thomas.petazzoni@bootlin.com" target="_blank">thomas.petazzoni@bootlin.com</a>&gt;<br></blockquote><div><br></div><div>Acked-by: Francois Perrad &lt;<a href="mailto:francois.perrad@gadz.org">francois.perrad@gadz.org</a>&gt;</div><div> <br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
---<br>
 package/<a href="http://pkg-luarocks.mk" rel="noreferrer" target="_blank">pkg-luarocks.mk</a> | 2 +-<br>
 1 file changed, 1 insertion(+), 1 deletion(-)<br>
<br>
diff --git a/package/<a href="http://pkg-luarocks.mk" rel="noreferrer" target="_blank">pkg-luarocks.mk</a> b/package/<a href="http://pkg-luarocks.mk" rel="noreferrer" target="_blank">pkg-luarocks.mk</a><br>
index 29c5e66cd1..f0985433b7 100644<br>
--- a/package/<a href="http://pkg-luarocks.mk" rel="noreferrer" target="_blank">pkg-luarocks.mk</a><br>
+++ b/package/<a href="http://pkg-luarocks.mk" rel="noreferrer" target="_blank">pkg-luarocks.mk</a><br>
@@ -63,7 +63,7 @@ endif<br>
 #<br>
 ifndef $(2)_INSTALL_TARGET_CMDS<br>
 define $(2)_INSTALL_TARGET_CMDS<br>
-       cd $$($(2)_SRCDIR) &amp;&amp; $$(LUAROCKS_RUN_ENV) flock $$(TARGET_DIR) \<br>
+       cd $$($(2)_SRCDIR) &amp;&amp; $$(LUAROCKS_RUN_ENV) \<br>
                $$(LUAROCKS_RUN_CMD) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPTS)<br>
 endef<br>
 endif<br>
-- <br>
2.19.1<br>
<br>
</blockquote></div></div>
Thomas Petazzoni Nov. 19, 2018, 8:46 p.m. UTC | #2
Hello,

On Mon, 19 Nov 2018 11:32:26 +0100, Thomas Petazzoni wrote:
> In commit 22b327fc743b48a33aec0a9190bd67118641b294 ("pkg-luarocks: fix
> top-level parallel makefile support"), a flock on $(TARGET_DIR) was
> added to ensure that two Luarocks packages are not installed at the
> same time.
> 
> However, to support top-level parallel build, we have now clearly
> decided that per-package folders is a requirement. Therefore,
> TARGET_DIR is anyway going to be different for each package, making
> this flock unnecessary.
> 
> Trying to use top-level parallel build without per-package folder is
> simply not supported, so this commit drops the unnecessary flock.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/pkg-luarocks.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index 29c5e66cd1..f0985433b7 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -63,7 +63,7 @@  endif
 #
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
-	cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) flock $$(TARGET_DIR) \
+	cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) \
 		$$(LUAROCKS_RUN_CMD) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPTS)
 endef
 endif