diff mbox series

[V2,3/4] pkg-perl: add a target which upgrades all packages from metacpan

Message ID 20181011161248.13457-4-francois.perrad@gadz.org
State Rejected
Headers show
Series scancpan | expand

Commit Message

Francois Perrad Oct. 11, 2018, 4:12 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-perl.mk | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Arnout Vandecappelle Oct. 23, 2018, 11:50 p.m. UTC | #1
Hi Francois,

On 10/11/18 5:12 PM, Francois Perrad wrote:
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/pkg-perl.mk | 9 +++++++++
>  1 file changed, 9 insertions(+)
> 
> diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
> index 07348bd5d..74a116075 100644
> --- a/package/pkg-perl.mk
> +++ b/package/pkg-perl.mk
> @@ -57,6 +57,10 @@ endif
>  #       used no matter the setting
>  $(2)_PREFER_INSTALLER ?= MB
>  
> +ifeq ($(4),target)
> +SCANCPAN_ALL_DISTRIB += $$($(2)_DISTNAME)
> +endif
> +
>  #
>  # Configure step. Only define it if not already defined by the package
>  # .mk file. And take care of the differences between host and target
> @@ -199,6 +203,11 @@ $(call inner-generic-package,$(1),$(2),$(3),$(4))
>  
>  endef
>  
> +# global target which upgrades all packages
> +.PHONY: scancpan
> +scancpan:
> +	utils/scancpan -force -target $(SCANCPAN_ALL_DISTRIB)

 I don't agree with this patch. When people post package bumps, our assumption
is that they actually use the package and have tested it after the bump. A
target that just blindly bumps everything is not what we want.

 Therefore, I've marked this patch as rejected in patchwork.

 Regards,
 Arnout
diff mbox series

Patch

diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
index 07348bd5d..74a116075 100644
--- a/package/pkg-perl.mk
+++ b/package/pkg-perl.mk
@@ -57,6 +57,10 @@  endif
 #       used no matter the setting
 $(2)_PREFER_INSTALLER ?= MB
 
+ifeq ($(4),target)
+SCANCPAN_ALL_DISTRIB += $$($(2)_DISTNAME)
+endif
+
 #
 # Configure step. Only define it if not already defined by the package
 # .mk file. And take care of the differences between host and target
@@ -199,6 +203,11 @@  $(call inner-generic-package,$(1),$(2),$(3),$(4))
 
 endef
 
+# global target which upgrades all packages
+.PHONY: scancpan
+scancpan:
+	utils/scancpan -force -target $(SCANCPAN_ALL_DISTRIB)
+
 ################################################################################
 # perl-package -- the target generator macro for Perl packages
 ################################################################################