diff mbox series

[1/1] pkg-waf: add support for <pkg>_SUBDIR

Message ID 20181010144412.3408-1-lionel.orry@gmail.com
State Not Applicable
Headers show
Series [1/1] pkg-waf: add support for <pkg>_SUBDIR | expand

Commit Message

Lionel Orry Oct. 10, 2018, 2:44 p.m. UTC
In the Buildroot manual, it is specified that the Waf-based
infrastructure supports the <pkg>_SUBDIR variable, which was not true.

This patch makes use of this variable by changing to the given
sub-directory before executing waf commands.

Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
---
 package/pkg-waf.mk | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Patzlaff, Marcel Oct. 10, 2018, 3:06 p.m. UTC | #1
Hi Lionel,

how is this patch different from 
https://patchwork.ozlabs.org/patch/971700/ ?

Geschäftsführung: Susanne Kunschert, Thomas Pilz
Pilz GmbH & Co. KG, Sitz: Ostfildern, HRA 210 893, Amtsgericht Stuttgart
Kompl. Ges. Peter Pilz GmbH, Sitz: Ostfildern, HRB 210 612, Amtsgericht Stuttgart
Umsatzsteuer: ID-Nr. DE 145 355 773, WEEE-Reg.-Nr. DE 71636849
This email is intended solely for the use of the named address(es). Any unauthorised disclosure, copying or distribution of these confidential information contained therein, or the taking of any action based on it, is prohibited. The sender disclaims any liability for the integrity of this email. Legally binding declarations must be in written form.
Umweltschutz liegt uns am Herzen! - Bitte denken Sie an unsere Umwelt, bevor Sie diese E-Mail drucken.
We do care about the environment! - Please consider the environment before printing this e-mail.
Lionel Orry Oct. 10, 2018, 3:10 p.m. UTC | #2
On Wed, Oct 10, 2018 at 5:06 PM Marcel Patzlaff <M.Patzlaff@pilz.de> wrote:
>
> Hi Lionel,
>
> how is this patch different from
> https://patchwork.ozlabs.org/patch/971700/ ?
>
> Geschäftsführung: Susanne Kunschert, Thomas Pilz
> Pilz GmbH & Co. KG, Sitz: Ostfildern, HRA 210 893, Amtsgericht Stuttgart
> Kompl. Ges. Peter Pilz GmbH, Sitz: Ostfildern, HRB 210 612, Amtsgericht Stuttgart
> Umsatzsteuer: ID-Nr. DE 145 355 773, WEEE-Reg.-Nr. DE 71636849
> This email is intended solely for the use of the named address(es). Any unauthorised disclosure, copying or distribution of these confidential information contained therein, or the taking of any action based on it, is prohibited. The sender disclaims any liability for the integrity of this email. Legally binding declarations must be in written form.
> Umweltschutz liegt uns am Herzen! - Bitte denken Sie an unsere Umwelt, bevor Sie diese E-Mail drucken.
> We do care about the environment! - Please consider the environment before printing this e-mail.

Hi Marcel,

This is not different, it's the same version but it seemed to be the
previous email was wrongly sent (because I could not use git
send-email) and it seemed to me that I needed to re-send it properly
for the mailing-list to receive it.

So, I apologise for this duplicated sending and the noise it provoked
on the line.

Best regards,
Lionel
diff mbox series

Patch

diff --git a/package/pkg-waf.mk b/package/pkg-waf.mk
index e5b606f063..826b73291b 100644
--- a/package/pkg-waf.mk
+++ b/package/pkg-waf.mk
@@ -54,13 +54,15 @@  $(2)_INSTALL_STAGING_OPTS		?=
 $(2)_INSTALL_TARGET_OPTS		?=
 $(2)_WAF_OPTS				?=
 
+$(2)_SRCDIR			= $$($(2)_DIR)/$$($(2)_SUBDIR)
+
 #
 # Configure step. Only define it if not already defined by the package
 # .mk file.
 #
 ifndef $(2)_CONFIGURE_CMDS
 define $(2)_CONFIGURE_CMDS
-	cd $$(@D) && \
+	cd $$($$(PKG)_SRCDIR) && \
 	$$(TARGET_CONFIGURE_OPTS) \
 	$$($(2)_CONF_ENV) \
 	$$(HOST_DIR)/bin/python2 $$($(2)_WAF) configure \
@@ -77,7 +79,7 @@  endif
 #
 ifndef $(2)_BUILD_CMDS
 define $(2)_BUILD_CMDS
-	cd $$(@D) && \
+	cd $$($$(PKG)_SRCDIR) && \
 	$$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
 		build -j $$(PARALLEL_JOBS) $$($(2)_BUILD_OPTS) \
 		$$($(2)_WAF_OPTS)
@@ -90,7 +92,7 @@  endif
 #
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
-	cd $$(@D) && \
+	cd $$($$(PKG)_SRCDIR) && \
 	$$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
 		install --destdir=$$(STAGING_DIR) \
 		$$($(2)_INSTALL_STAGING_OPTS) \
@@ -104,7 +106,7 @@  endif
 #
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
-	cd $$(@D) && \
+	cd $$($$(PKG)_SRCDIR) && \
 	$$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
 		install --destdir=$$(TARGET_DIR) \
 		$$($(2)_INSTALL_TARGET_OPTS) \