diff mbox series

[v2,1/1] bird: new package

Message ID 20180927222100.6564-1-adrien@gallouet.fr
State Accepted
Headers show
Series [v2,1/1] bird: new package | expand

Commit Message

Adrien Gallouët Sept. 27, 2018, 10:21 p.m. UTC
The BIRD project aims to develop a dynamic IP routing daemon with full support
of all modern routing protocols, easy to use configuration interface and
powerful route filtering language

Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
---
Changes v1 -> v2 (after Baruch Siach review)
- Add a comment for the use of autoreconf
- Use github helper

Comments

Thomas Petazzoni Oct. 9, 2018, 12:47 p.m. UTC | #1
Hello Adrien,

On Thu, 27 Sep 2018 22:21:01 +0000, Adrien Gallouët wrote:
> The BIRD project aims to develop a dynamic IP routing daemon with full support
> of all modern routing protocols, easy to use configuration interface and
> powerful route filtering language
> 
> Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
> ---
> Changes v1 -> v2 (after Baruch Siach review)
> - Add a comment for the use of autoreconf
> - Use github helper

I've applied your patch, after doing a number of changes:

    [Thomas:
     - Do not make ncurses/readline mandatory dependencies, since they are
       not. They are only needed when building the BIRD client. Added a
       Config.in sub-option to enable/disable the client. As part of this,
       added ncurses/readline to <pkg>_DEPENDENCIES.
     - Add a patch to fix the installation when the BIRD client is
       disabled, the patch has been submitted upstream.
     - Added host-flex and host-bison to <pkg>_DEPENDENCIES since
       flex/bison are used during the build process.
     - Add BR2_USE_MMU dependency, the code uses fork()
     - Fix alphabetic ordering in DEVELOPERS file.]

Thanks for this contribution!

Thomas
Adrien Gallouët Oct. 9, 2018, 1:30 p.m. UTC | #2
Hi Thomas,

Thanks a lot :)


On Tue, Oct 9, 2018 at 2:48 PM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello Adrien,
>
> On Thu, 27 Sep 2018 22:21:01 +0000, Adrien Gallouët wrote:
> > The BIRD project aims to develop a dynamic IP routing daemon with full support
> > of all modern routing protocols, easy to use configuration interface and
> > powerful route filtering language
> >
> > Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
> > ---
> > Changes v1 -> v2 (after Baruch Siach review)
> > - Add a comment for the use of autoreconf
> > - Use github helper
>
> I've applied your patch, after doing a number of changes:
>
>     [Thomas:
>      - Do not make ncurses/readline mandatory dependencies, since they are
>        not. They are only needed when building the BIRD client. Added a
>        Config.in sub-option to enable/disable the client. As part of this,
>        added ncurses/readline to <pkg>_DEPENDENCIES.
>      - Add a patch to fix the installation when the BIRD client is
>        disabled, the patch has been submitted upstream.
>      - Added host-flex and host-bison to <pkg>_DEPENDENCIES since
>        flex/bison are used during the build process.
>      - Add BR2_USE_MMU dependency, the code uses fork()
>      - Fix alphabetic ordering in DEVELOPERS file.]
>
> Thanks for this contribution!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 0335aef3b1..a256067004 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -72,6 +72,7 @@  F:	package/woff2/
 
 N:	Adrien Gallouët <adrien@gallouet.fr>
 F:	package/glorytun/
+F:	package/bird/
 
 N:	Aleksander Morgado <aleksander@aleksander.es>
 F:	package/libmbim/
diff --git a/package/Config.in b/package/Config.in
index 52f11c407a..73bb209c66 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1743,6 +1743,7 @@  menu "Networking applications"
 	source "package/batctl/Config.in"
 	source "package/bcusdk/Config.in"
 	source "package/bind/Config.in"
+	source "package/bird/Config.in"
 	source "package/bluez-tools/Config.in"
 	source "package/bluez_utils/Config.in"
 	source "package/bluez5_utils/Config.in"
diff --git a/package/bird/Config.in b/package/bird/Config.in
new file mode 100644
index 0000000000..6e4e43505a
--- /dev/null
+++ b/package/bird/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_BIRD
+	bool "bird"
+	select BR2_PACKAGE_NCURSES
+	select BR2_PACKAGE_READLINE
+	help
+	  BIRD Internet Routing Daemon
+
+	  The BIRD project aims to develop a dynamic IP routing daemon with full support
+	  of all modern routing protocols, easy to use configuration interface and
+	  powerful route filtering language
+
+	  http://bird.network.cz/
diff --git a/package/bird/bird.hash b/package/bird/bird.hash
new file mode 100644
index 0000000000..449e8afd8d
--- /dev/null
+++ b/package/bird/bird.hash
@@ -0,0 +1,2 @@ 
+sha256 bd42d48fbcc2c0046d544f1183cd98193ff15b792d332ff45f386b0180b09335  bird-v2.0.2.tar.gz
+sha256 f018596a97af0108efc446320631e2fddc0c1d1f3ffab3129327ccdb4f0c29ed  README
diff --git a/package/bird/bird.mk b/package/bird/bird.mk
new file mode 100644
index 0000000000..f45baadab2
--- /dev/null
+++ b/package/bird/bird.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# bird
+#
+################################################################################
+
+BIRD_VERSION = v2.0.2
+BIRD_SITE = $(call github,BIRD,bird,$(BIRD_VERSION))
+BIRD_LICENSE = GPL-2.0+
+BIRD_LICENSE_FILES = README
+
+# autoreconf is needed since the package is fetched from github
+BIRD_AUTORECONF = YES
+
+$(eval $(autotools-package))