diff mbox series

pkg-perl: fix PERL_INC in generated Makefile

Message ID 20180914032514.15116-1-francois.perrad@gadz.org
State Accepted
Headers show
Series pkg-perl: fix PERL_INC in generated Makefile | expand

Commit Message

Francois Perrad Sept. 14, 2018, 3:25 a.m. UTC
when directly setting PERL_INC with a path to STAGING_DIR,
the generated Makefile contains a PERL_INC with a path to HOST_DIR

when setting PERL_ARCHLIB, PERL_INC is generated as $(PERL_ARCHLIB)/CORE

fix this kind of build failure:
http://autobuild.buildroot.net/results/8934f2c203f8b61519dba94188985f1a9261de9a/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-perl.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Sept. 14, 2018, 8:15 p.m. UTC | #1
Hello,

On Fri, 14 Sep 2018 05:25:14 +0200, Francois Perrad wrote:
> when directly setting PERL_INC with a path to STAGING_DIR,
> the generated Makefile contains a PERL_INC with a path to HOST_DIR
> 
> when setting PERL_ARCHLIB, PERL_INC is generated as $(PERL_ARCHLIB)/CORE
> 
> fix this kind of build failure:
> http://autobuild.buildroot.net/results/8934f2c203f8b61519dba94188985f1a9261de9a/
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/pkg-perl.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
index ebc6710bd..07348bd5d 100644
--- a/package/pkg-perl.mk
+++ b/package/pkg-perl.mk
@@ -102,7 +102,7 @@  define $(2)_CONFIGURE_CMDS
 			LD="$$(TARGET_CC)" \
 			LDDLFLAGS="-shared $$(TARGET_LDFLAGS)" \
 			LDFLAGS="$$(TARGET_LDFLAGS)" \
-			PERL_INC=$$(STAGING_DIR)/usr/lib/perl5/$$(PERL_VERSION)/$$(PERL_ARCHNAME)/CORE \
+			PERL_ARCHLIB=$$(STAGING_DIR)/usr/lib/perl5/$$(PERL_VERSION)/$$(PERL_ARCHNAME) \
 			DESTDIR=$$(TARGET_DIR) \
 			INSTALLDIRS=vendor \
 			INSTALLVENDORLIB=/usr/lib/perl5/site_perl/$$(PERL_VERSION) \