diff mbox series

[v2,3/3] package/glibc: allow to specify host-make

Message ID 20180903191933.26080-3-romain.naour@gmail.com
State Accepted
Headers show
Series [v2,1/3] package/make: add host variant | expand

Commit Message

Romain Naour Sept. 3, 2018, 7:19 p.m. UTC
Use host-make package if GNU make from the host machine is too old.

Use the newly introduced BR2_MAKE_HOST_DEPENDENCY and BR2_MAKE to
provide respectively, host-make dependency and the path to the GNU
make binary to use for building glibc.

Fixes:
http://autobuild.buildroot.net/results/576/5760ea2635d9aecc9c789494a8b2cc73a1af1ceb
http://autobuild.buildroot.net/results/583/58347b94884eee2db28740486eda280e8c08e22f
http://autobuild.buildroot.net/results/dc7/dc7c8cd548409864ab0055e196c0280457a5fb5f

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Baruch Siach <baruch@tkos.co.il>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/glibc/glibc.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Matt Weber Sept. 5, 2018, 1:40 a.m. UTC | #1
Romain,

On Mon, Sep 3, 2018 at 2:19 PM Romain Naour <romain.naour@gmail.com> wrote:
>
> Use host-make package if GNU make from the host machine is too old.
>
> Use the newly introduced BR2_MAKE_HOST_DEPENDENCY and BR2_MAKE to
> provide respectively, host-make dependency and the path to the GNU
> make binary to use for building glibc.
>
> Fixes:
> http://autobuild.buildroot.net/results/576/5760ea2635d9aecc9c789494a8b2cc73a1af1ceb
> http://autobuild.buildroot.net/results/583/58347b94884eee2db28740486eda280e8c08e22f
> http://autobuild.buildroot.net/results/dc7/dc7c8cd548409864ab0055e196c0280457a5fb5f
>
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Cc: Baruch Siach <baruch@tkos.co.il>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>

> ---
>  package/glibc/glibc.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
> index 399cf395ce..a2eb8714b1 100644
> --- a/package/glibc/glibc.mk
> +++ b/package/glibc/glibc.mk
> @@ -28,7 +28,12 @@ GLIBC_ADD_TOOLCHAIN_DEPENDENCY = NO
>
>  # Before glibc is configured, we must have the first stage
>  # cross-compiler and the kernel headers
> -GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk
> +GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk \
> +       $(BR2_MAKE_HOST_DEPENDENCY)
> +
> +# glibc requires make >= 4.0 since 2.28 release.
> +# https://www.sourceware.org/ml/libc-alpha/2018-08/msg00003.html
> +GLIBC_MAKE = $(BR2_MAKE)
>
>  GLIBC_SUBDIR = build
>
> --
> 2.14.4
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Sept. 8, 2018, 9:38 p.m. UTC | #2
Hello,

On Mon,  3 Sep 2018 21:19:33 +0200, Romain Naour wrote:
> Use host-make package if GNU make from the host machine is too old.
> 
> Use the newly introduced BR2_MAKE_HOST_DEPENDENCY and BR2_MAKE to
> provide respectively, host-make dependency and the path to the GNU
> make binary to use for building glibc.
> 
> Fixes:
> http://autobuild.buildroot.net/results/576/5760ea2635d9aecc9c789494a8b2cc73a1af1ceb
> http://autobuild.buildroot.net/results/583/58347b94884eee2db28740486eda280e8c08e22f
> http://autobuild.buildroot.net/results/dc7/dc7c8cd548409864ab0055e196c0280457a5fb5f
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Cc: Baruch Siach <baruch@tkos.co.il>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/glibc/glibc.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 399cf395ce..a2eb8714b1 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -28,7 +28,12 @@  GLIBC_ADD_TOOLCHAIN_DEPENDENCY = NO
 
 # Before glibc is configured, we must have the first stage
 # cross-compiler and the kernel headers
-GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk
+GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk \
+	$(BR2_MAKE_HOST_DEPENDENCY)
+
+# glibc requires make >= 4.0 since 2.28 release.
+# https://www.sourceware.org/ml/libc-alpha/2018-08/msg00003.html
+GLIBC_MAKE = $(BR2_MAKE)
 
 GLIBC_SUBDIR = build