diff mbox series

package/cutelyst: Fix build dependencies

Message ID 20180801114738.5044-1-dantti12@gmail.com
State Accepted
Headers show
Series package/cutelyst: Fix build dependencies | expand

Commit Message

Daniel Nicoletti Aug. 1, 2018, 11:47 a.m. UTC
Add missing optional dependencies need when
the dependency was available, disabling Grantlee
plugin for now as it failed to build.

Signed-off-by: Daniel Nicoletti <dantti12@gmail.com>
---
 package/cutelyst/cutelyst.mk | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Aug. 1, 2018, 12:27 p.m. UTC | #1
Hello Daniel,

Thanks for providing this fix!

On Wed,  1 Aug 2018 08:47:38 -0300, Daniel Nicoletti wrote:
> Add missing optional dependencies need when
> the dependency was available, disabling Grantlee
> plugin for now as it failed to build.
> 
> Signed-off-by: Daniel Nicoletti <dantti12@gmail.com>

I've applied, but after changing one thing:

> ---
>  package/cutelyst/cutelyst.mk | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/package/cutelyst/cutelyst.mk b/package/cutelyst/cutelyst.mk
> index 438ac091c6..2d1c9b1532 100644
> --- a/package/cutelyst/cutelyst.mk
> +++ b/package/cutelyst/cutelyst.mk
> @@ -15,20 +15,16 @@ CUTELYST_DEPENDENCIES = qt5base
>  CUTELYST_CONF_OPTS += \
>  	-DPLUGIN_CSRFPROTECTION=ON
>  
> -ifeq ($(BR2_PACKAGE_GRANTLEE),y)
> -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=ON
> -else
> -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=OFF
> -endif

I've kept an unconditional -DPLUGIN_VIEW_GRANTLEE=OFF to make sure that
grantlee support is always disabled, even if grantlee gets
built/installed before cutelyst.

However, there are other build issues of the cutelyst package which
don't seem to be related:

 - http://autobuild.buildroot.net/results/b4b/b4bd0807fed721d8f553f1392e7d1fa51545d046/build-end.log

   Lots of Qt/C++ errors.

 - http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log

   Doxygen missing. We have a host-doxygen package in Buildroot, but it
   would be a lot nicer of Cutelyst would not require Doxygen. Any
   chance to make this optional ? We don't really care about building
   documentation in the context of Buildroot.

 - http://autobuild.buildroot.net/results/771/7716878c3a26b93417188ad7eac91ace172815bb/build-end.log

   lrelease not found

Could you have a look at those remaining build issues ?

Thanks!

Thomas
Daniel Nicoletti Aug. 1, 2018, 12:55 p.m. UTC | #2
Em qua, 1 de ago de 2018 às 09:27, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> escreveu:
>
> Hello Daniel,
>
> Thanks for providing this fix!
You welcome

>
> On Wed,  1 Aug 2018 08:47:38 -0300, Daniel Nicoletti wrote:
> > Add missing optional dependencies need when
> > the dependency was available, disabling Grantlee
> > plugin for now as it failed to build.
> >
> > Signed-off-by: Daniel Nicoletti <dantti12@gmail.com>
>
> I've applied, but after changing one thing:
>
> > ---
> >  package/cutelyst/cutelyst.mk | 8 ++------
> >  1 file changed, 2 insertions(+), 6 deletions(-)
> >
> > diff --git a/package/cutelyst/cutelyst.mk b/package/cutelyst/cutelyst.mk
> > index 438ac091c6..2d1c9b1532 100644
> > --- a/package/cutelyst/cutelyst.mk
> > +++ b/package/cutelyst/cutelyst.mk
> > @@ -15,20 +15,16 @@ CUTELYST_DEPENDENCIES = qt5base
> >  CUTELYST_CONF_OPTS += \
> >       -DPLUGIN_CSRFPROTECTION=ON
> >
> > -ifeq ($(BR2_PACKAGE_GRANTLEE),y)
> > -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=ON
> > -else
> > -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=OFF
> > -endif
>
> I've kept an unconditional -DPLUGIN_VIEW_GRANTLEE=OFF to make sure that
> grantlee support is always disabled, even if grantlee gets
> built/installed before cutelyst.
By default all plugins that require external deps are disabled, but
it's harmless anyway

>
> However, there are other build issues of the cutelyst package which
> don't seem to be related:
>
>  - http://autobuild.buildroot.net/results/b4b/b4bd0807fed721d8f553f1392e7d1fa51545d046/build-end.log
>
>    Lots of Qt/C++ errors.
Yeah, I have fixed a few right after the release, as they usually build fine
when warnings are not enabled...

>
>  - http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log
>
>    Doxygen missing. We have a host-doxygen package in Buildroot, but it
>    would be a lot nicer of Cutelyst would not require Doxygen. Any
>    chance to make this optional ? We don't really care about building
>    documentation in the context of Buildroot.
It does not require, it only uses if found and if make docs, I could
add a BUILD_DOCS option but it's not very important IMO.

>
>  - http://autobuild.buildroot.net/results/771/7716878c3a26b93417188ad7eac91ace172815bb/build-end.log
>
>    lrelease not found
>
> Could you have a look at those remaining build issues ?
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> https://bootlin.com
Daniel Nicoletti Aug. 1, 2018, 1 p.m. UTC | #3
Oh, and in this build:
http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log

it failed not because of doxygen, but because it could not find libpwquality,
I guess it's an old build.
Em qua, 1 de ago de 2018 às 09:55, Daniel Nicoletti
<dantti12@gmail.com> escreveu:
>
> Em qua, 1 de ago de 2018 às 09:27, Thomas Petazzoni
> <thomas.petazzoni@bootlin.com> escreveu:
> >
> > Hello Daniel,
> >
> > Thanks for providing this fix!
> You welcome
>
> >
> > On Wed,  1 Aug 2018 08:47:38 -0300, Daniel Nicoletti wrote:
> > > Add missing optional dependencies need when
> > > the dependency was available, disabling Grantlee
> > > plugin for now as it failed to build.
> > >
> > > Signed-off-by: Daniel Nicoletti <dantti12@gmail.com>
> >
> > I've applied, but after changing one thing:
> >
> > > ---
> > >  package/cutelyst/cutelyst.mk | 8 ++------
> > >  1 file changed, 2 insertions(+), 6 deletions(-)
> > >
> > > diff --git a/package/cutelyst/cutelyst.mk b/package/cutelyst/cutelyst.mk
> > > index 438ac091c6..2d1c9b1532 100644
> > > --- a/package/cutelyst/cutelyst.mk
> > > +++ b/package/cutelyst/cutelyst.mk
> > > @@ -15,20 +15,16 @@ CUTELYST_DEPENDENCIES = qt5base
> > >  CUTELYST_CONF_OPTS += \
> > >       -DPLUGIN_CSRFPROTECTION=ON
> > >
> > > -ifeq ($(BR2_PACKAGE_GRANTLEE),y)
> > > -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=ON
> > > -else
> > > -CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=OFF
> > > -endif
> >
> > I've kept an unconditional -DPLUGIN_VIEW_GRANTLEE=OFF to make sure that
> > grantlee support is always disabled, even if grantlee gets
> > built/installed before cutelyst.
> By default all plugins that require external deps are disabled, but
> it's harmless anyway
>
> >
> > However, there are other build issues of the cutelyst package which
> > don't seem to be related:
> >
> >  - http://autobuild.buildroot.net/results/b4b/b4bd0807fed721d8f553f1392e7d1fa51545d046/build-end.log
> >
> >    Lots of Qt/C++ errors.
> Yeah, I have fixed a few right after the release, as they usually build fine
> when warnings are not enabled...
>
> >
> >  - http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log
> >
> >    Doxygen missing. We have a host-doxygen package in Buildroot, but it
> >    would be a lot nicer of Cutelyst would not require Doxygen. Any
> >    chance to make this optional ? We don't really care about building
> >    documentation in the context of Buildroot.
> It does not require, it only uses if found and if make docs, I could
> add a BUILD_DOCS option but it's not very important IMO.
>
> >
> >  - http://autobuild.buildroot.net/results/771/7716878c3a26b93417188ad7eac91ace172815bb/build-end.log
> >
> >    lrelease not found
> >
> > Could you have a look at those remaining build issues ?
> >
> > Thanks!
> >
> > Thomas
> > --
> > Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
>
>
>
> --
> Daniel Nicoletti
>
> KDE Developer - http://dantti.wordpress.com
Thomas Petazzoni Aug. 1, 2018, 1:06 p.m. UTC | #4
Hello,

On Wed, 1 Aug 2018 09:55:43 -0300, Daniel Nicoletti wrote:

> > However, there are other build issues of the cutelyst package which
> > don't seem to be related:
> >
> >  - http://autobuild.buildroot.net/results/b4b/b4bd0807fed721d8f553f1392e7d1fa51545d046/build-end.log
> >
> >    Lots of Qt/C++ errors.  
> Yeah, I have fixed a few right after the release, as they usually build fine
> when warnings are not enabled...

I'm not sure what you mean here. These errors still occur in the
autobuilders. Do we need to bump the cutelyst version ?

> >  - http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log
> >
> >    Doxygen missing. We have a host-doxygen package in Buildroot, but it
> >    would be a lot nicer of Cutelyst would not require Doxygen. Any
> >    chance to make this optional ? We don't really care about building
> >    documentation in the context of Buildroot.  
> It does not require, it only uses if found and if make docs, I could
> add a BUILD_DOCS option but it's not very important IMO.

So according to your next e-mail, this failure is not due to
lrelease/doxygen missing, but only because libpwquality could not be
found ?

Best regards,

Thomas
Daniel Nicoletti Aug. 1, 2018, 1:11 p.m. UTC | #5
Em qua, 1 de ago de 2018 às 10:06, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> escreveu:
>
> Hello,
>
> On Wed, 1 Aug 2018 09:55:43 -0300, Daniel Nicoletti wrote:
>
> > > However, there are other build issues of the cutelyst package which
> > > don't seem to be related:
> > >
> > >  - http://autobuild.buildroot.net/results/b4b/b4bd0807fed721d8f553f1392e7d1fa51545d046/build-end.log
> > >
> > >    Lots of Qt/C++ errors.
> > Yeah, I have fixed a few right after the release, as they usually build fine
> > when warnings are not enabled...
>
> I'm not sure what you mean here. These errors still occur in the
> autobuilders. Do we need to bump the cutelyst version ?
Yes, I'll probably do a point release due that error, it's just one
besides the huge g++ output...

>
> > >  - http://autobuild.buildroot.net/results/555/555cf0cd59c9c832b15c604dae5bad3640f8b450/build-end.log
> > >
> > >    Doxygen missing. We have a host-doxygen package in Buildroot, but it
> > >    would be a lot nicer of Cutelyst would not require Doxygen. Any
> > >    chance to make this optional ? We don't really care about building
> > >    documentation in the context of Buildroot.
> > It does not require, it only uses if found and if make docs, I could
> > add a BUILD_DOCS option but it's not very important IMO.
>
> So according to your next e-mail, this failure is not due to
> lrelease/doxygen missing, but only because libpwquality could not be
> found ?
yes, otherwise the other link wouldn't had issues at compilation time.

>
> Best regards,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/package/cutelyst/cutelyst.mk b/package/cutelyst/cutelyst.mk
index 438ac091c6..2d1c9b1532 100644
--- a/package/cutelyst/cutelyst.mk
+++ b/package/cutelyst/cutelyst.mk
@@ -15,20 +15,16 @@  CUTELYST_DEPENDENCIES = qt5base
 CUTELYST_CONF_OPTS += \
 	-DPLUGIN_CSRFPROTECTION=ON
 
-ifeq ($(BR2_PACKAGE_GRANTLEE),y)
-CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=ON
-else
-CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_LIBPWQUALITY),y)
 CUTELYST_CONF_OPTS += -DPLUGIN_VALIDATOR_PWQUALITY=ON
+CUTELYST_DEPENDENCIES += libpwquality
 else
 CUTELYST_CONF_OPTS += -DPLUGIN_VALIDATOR_PWQUALITY=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_JEMALLOC),y)
 CUTELYST_CONF_OPTS += -DUSE_JEMALLOC=ON
+CUTELYST_DEPENDENCIES += jemalloc
 else
 CUTELYST_CONF_OPTS += -DUSE_JEMALLOC=OFF
 endif