diff mbox series

[RFC,6/8] llvm: bump to version 6.0.0

Message ID 20180608225932.13127-7-joseph.kogut@gmail.com
State Superseded
Headers show
Series chromium: new package | expand

Commit Message

Joseph Kogut June 8, 2018, 10:59 p.m. UTC
Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
---
 ...type-in-ORC-readMem-client-interface.patch | 37 -------------------
 package/llvm/llvm.hash                        |  2 +-
 package/llvm/llvm.mk                          |  2 +-
 3 files changed, 2 insertions(+), 39 deletions(-)
 delete mode 100644 package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch

Comments

Valentin Korenblit June 12, 2018, 2:34 p.m. UTC | #1
Joseph, all,

On 09/06/2018 00:59, Joseph Kogut wrote:
> Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
> ---
>   ...type-in-ORC-readMem-client-interface.patch | 37 -------------------
>   package/llvm/llvm.hash                        |  2 +-
>   package/llvm/llvm.mk                          |  2 +-
>   3 files changed, 2 insertions(+), 39 deletions(-)
>   delete mode 100644 package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch
>   
> -LLVM_VERSION = 5.0.2
> +LLVM_VERSION = 6.0.0
>   LLVM_SITE = http://llvm.org/releases/$(LLVM_VERSION)
>   LLVM_SOURCE = llvm-$(LLVM_VERSION).src.tar.xz
>   LLVM_LICENSE = NCSA

Tested-by: Valentin Korenblit <valentin.korenblit@smile.fr>

I've applied the patch and tested llvmpipe on ARM and x86. My only
doubt is whether we should also keep llvm 5 (no longer mantained).
Apparently there haven't been changes in the API, most changes are
related to backends: https://releases.llvm.org/6.0.0/docs/ReleaseNotes.html.

I ask this question because this topic was discussed during the meeting:
https://elinux.org/Buildroot:DeveloperDaysFOSDEM2018#LLVM.2FClang

I believe we could just bump to 6.0.0 as currently there is only Mesa
using this package.

Best regards,

Valentin
Joseph Kogut June 12, 2018, 5:07 p.m. UTC | #2
Valentin,

On Tue, Jun 12, 2018 at 7:34 AM Valentin Korenblit
<valentin.korenblit@smile.fr> wrote:
>
> Joseph, all,
>
> On 09/06/2018 00:59, Joseph Kogut wrote:
> > Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
> > ---
> >   ...type-in-ORC-readMem-client-interface.patch | 37 -------------------
> >   package/llvm/llvm.hash                        |  2 +-
> >   package/llvm/llvm.mk                          |  2 +-
> >   3 files changed, 2 insertions(+), 39 deletions(-)
> >   delete mode 100644 package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch
> >
> > -LLVM_VERSION = 5.0.2
> > +LLVM_VERSION = 6.0.0
> >   LLVM_SITE = http://llvm.org/releases/$(LLVM_VERSION)
> >   LLVM_SOURCE = llvm-$(LLVM_VERSION).src.tar.xz
> >   LLVM_LICENSE = NCSA
>
> Tested-by: Valentin Korenblit <valentin.korenblit@smile.fr>
>
> I've applied the patch and tested llvmpipe on ARM and x86. My only
> doubt is whether we should also keep llvm 5 (no longer mantained).
> Apparently there haven't been changes in the API, most changes are
> related to backends: https://releases.llvm.org/6.0.0/docs/ReleaseNotes.html.
>
> I ask this question because this topic was discussed during the meeting:
> https://elinux.org/Buildroot:DeveloperDaysFOSDEM2018#LLVM.2FClang
>

I was curious about that as well, as I read the notes about the meeting.

If LLVM 5.0 is no longer maintained, I don't see any reason to
continue supporting it, especially if the API hasn't broken.

> I believe we could just bump to 6.0.0 as currently there is only Mesa
> using this package.
>

On the other hand, there's no way for us to know if someone is using
LLVM in their own application that would break by upgrading. I think
the answer to that problem is that they should stay on a Buildroot
release branch that packages the version they need, or they should
submit patches to allow the older version to be selected.

With 6.0.0 being the current stable release, I do think it makes sense
for us to bump it.

Best,
Joseph
diff mbox series

Patch

diff --git a/package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch b/package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch
deleted file mode 100644
index 0343b4c7e8..0000000000
--- a/package/llvm/0001-Fix-return-type-in-ORC-readMem-client-interface.patch
+++ /dev/null
@@ -1,37 +0,0 @@ 
-From 72ea6ea635d5b5a88f411710daf7e1d340d232d8 Mon Sep 17 00:00:00 2001
-From: Tilmann Scheller <tschelle@redhat.com>
-Date: Thu, 1 Feb 2018 11:40:01 -0600
-Subject: [PATCH] Fix return type in ORC readMem() client interface.
-
-GCC 8.0.1 detects the type mismatch and causes the compilation to fail. Clang
-and earlier versions of GCC don't detect the issue.
-
-Fixes rhbz#1540620.
-
-This patch was taken from llvm5.0-5.0.1-7.fc28.src.rpm
-
-Link to bug: https://bugzilla.redhat.com/show_bug.cgi?id=1540620
-
-Signed-off-by: Valentin Korenblit <valentin.korenblit@smile.fr>
----
- include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-index da02250ba16..bed472e2e0e 100644
---- a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-+++ b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-@@ -713,8 +713,8 @@ private:
- 
-   uint32_t getTrampolineSize() const { return RemoteTrampolineSize; }
- 
--  Expected<std::vector<char>> readMem(char *Dst, JITTargetAddress Src,
--                                      uint64_t Size) {
-+  Expected<std::vector<uint8_t>> readMem(char *Dst, JITTargetAddress Src,
-+                                         uint64_t Size) {
-     // Check for an 'out-of-band' error, e.g. from an MM destructor.
-     if (ExistingError)
-       return std::move(ExistingError);
--- 
-2.14.3
-
diff --git a/package/llvm/llvm.hash b/package/llvm/llvm.hash
index 14f8bb4488..93bdf2e20e 100644
--- a/package/llvm/llvm.hash
+++ b/package/llvm/llvm.hash
@@ -1,3 +1,3 @@ 
 # locally calculated
-sha256 d522eda97835a9c75f0b88ddc81437e5edbb87dc2740686cb8647763855c2b3c  llvm-5.0.2.src.tar.xz
+sha256 1ff53c915b4e761ef400b803f07261ade637b0c269d99569f18040f3dcee4408  llvm-6.0.0.src.tar.xz
 sha256 abd4d8794808bacb1eb6924d49efafd9ab6eef88faaaeb5d3cfa13ee3670d672 LICENSE.TXT
diff --git a/package/llvm/llvm.mk b/package/llvm/llvm.mk
index 06f95c96f8..d2db05d94c 100644
--- a/package/llvm/llvm.mk
+++ b/package/llvm/llvm.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LLVM_VERSION = 5.0.2
+LLVM_VERSION = 6.0.0
 LLVM_SITE = http://llvm.org/releases/$(LLVM_VERSION)
 LLVM_SOURCE = llvm-$(LLVM_VERSION).src.tar.xz
 LLVM_LICENSE = NCSA