diff mbox series

[v2,1/1] libcap: only install shared version

Message ID 20180509084305.18797-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] libcap: only install shared version | expand

Commit Message

Fabrice Fontaine May 9, 2018, 8:43 a.m. UTC
If BR2_SHARED_LIBS is set, only install shared version of library
(continue to build both libraries through all target as there is no
libcap.so target but only a libcap.so.$(VERSION).$(MINOR))

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Thomas Petazzoni):
 - Update to have a clearer approach

 package/libcap/libcap.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni May 12, 2018, 7:02 a.m. UTC | #1
Hello,

On Wed,  9 May 2018 10:43:05 +0200, Fabrice Fontaine wrote:
> If BR2_SHARED_LIBS is set, only install shared version of library
> (continue to build both libraries through all target as there is no
> libcap.so target but only a libcap.so.$(VERSION).$(MINOR))
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Thomas Petazzoni):
>  - Update to have a clearer approach

Applied to master, thanks.

Thomas
Peter Korsgaard May 28, 2018, 2:24 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > If BR2_SHARED_LIBS is set, only install shared version of library
 > (continue to build both libraries through all target as there is no
 > libcap.so target but only a libcap.so.$(VERSION).$(MINOR))

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Thomas Petazzoni):
 >  - Update to have a clearer approach

Committed to 2018.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libcap/libcap.mk b/package/libcap/libcap.mk
index 48c2cb3456..a947fa0686 100644
--- a/package/libcap/libcap.mk
+++ b/package/libcap/libcap.mk
@@ -18,6 +18,9 @@  HOST_LIBCAP_DEPENDENCIES = host-gperf
 ifeq ($(BR2_STATIC_LIBS),y)
 LIBCAP_MAKE_TARGET = libcap.a libcap.pc
 LIBCAP_MAKE_INSTALL_TARGET = install-static
+else ifeq ($(BR2_SHARED_LIBS),y)
+LIBCAP_MAKE_TARGET = all
+LIBCAP_MAKE_INSTALL_TARGET = install-shared
 else
 LIBCAP_MAKE_TARGET = all
 LIBCAP_MAKE_INSTALL_TARGET = install