diff mbox series

core/pkg-infra: don't display "foo Downloading" when there's no source

Message ID 20180503201757.10822-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series core/pkg-infra: don't display "foo Downloading" when there's no source | expand

Commit Message

Yann E. MORIN May 3, 2018, 8:17 p.m. UTC
Commit ea55e1323 (core/pkg-infra: don't enforce site-method for extra
downloads) forgot to account for those packages that have nothing to
download, like the skeleton, or like virtual packages...

The side effect is that the message "foo Downloading" is thus
displayed when it should not be.

Fix that.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/pkg-generic.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni May 3, 2018, 9:08 p.m. UTC | #1
Hello,

On Thu,  3 May 2018 22:17:57 +0200, Yann E. MORIN wrote:
> Commit ea55e1323 (core/pkg-infra: don't enforce site-method for extra
> downloads) forgot to account for those packages that have nothing to
> download, like the skeleton, or like virtual packages...
> 
> The side effect is that the message "foo Downloading" is thus
> displayed when it should not be.
> 
> Fix that.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  package/pkg-generic.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index a6e6e2b22c..aa638a4b04 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -498,7 +498,7 @@  BR_NO_CHECK_HASH_FOR += $$($(2)_SOURCE)
 endif
 
 $(2)_ALL_DOWNLOADS = \
-	$$($(2)_SITE_METHOD)+$$($(2)_SITE)/$$($(2)_SOURCE) \
+	$$(if $$($(2)_SOURCE),$$($(2)_SITE_METHOD)+$$($(2)_SITE)/$$($(2)_SOURCE)) \
 	$$(foreach p,$$($(2)_PATCH) $$($(2)_EXTRA_DOWNLOADS),\
 		$$(if $$(findstring ://,$$(p)),$$(p),\
 			$$($(2)_SITE)/$$(p)))