diff mbox series

package/libcec: disable build infos

Message ID 20180418211330.13594-1-romain.naour@gmail.com
State Accepted
Headers show
Series package/libcec: disable build infos | expand

Commit Message

Romain Naour April 18, 2018, 9:13 p.m. UTC
Build infos can break the build due to missing terminating " character.

Fixes:
http://autobuild.buildroot.net/results/3b1/3b1182783fc958dfed96c6b1c097993662fc7308

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libcec/libcec.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni April 19, 2018, 9:35 p.m. UTC | #1
Hello,

On Wed, 18 Apr 2018 23:13:30 +0200, Romain Naour wrote:
> Build infos can break the build due to missing terminating " character.
> 
> Fixes:
> http://autobuild.buildroot.net/results/3b1/3b1182783fc958dfed96c6b1c097993662fc7308
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/libcec/libcec.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard May 1, 2018, 6:54 a.m. UTC | #2
>>>>> "Romain" == Romain Naour <romain.naour@gmail.com> writes:

 > Build infos can break the build due to missing terminating " character.
 > Fixes:
 > http://autobuild.buildroot.net/results/3b1/3b1182783fc958dfed96c6b1c097993662fc7308

 > Signed-off-by: Romain Naour <romain.naour@gmail.com>
 > Cc: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2018.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libcec/libcec.mk b/package/libcec/libcec.mk
index 6d14447958..99d1c8b2ba 100644
--- a/package/libcec/libcec.mk
+++ b/package/libcec/libcec.mk
@@ -37,4 +37,11 @@  ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
 LIBCEC_DEPENDENCIES += xlib_libXrandr
 endif
 
+# Disable information about how libCEC is compiled.
+LIBCEC_CONF_OPTS += -DHAVE_GIT_BIN="" \
+	-DHAVE_DATE_BIN="" \
+	-DHAVE_WHOAMI_BIN="" \
+	-DHAVE_HOSTNAME_BIN="" \
+	-DHAVE_UNAME_BIN=""
+
 $(eval $(cmake-package))