diff mbox series

[3/5] rust-bin: use HOST_RUST_BIN_DL_DIR instead of RUST_BIN_DL_DIR

Message ID 20180402183626.7769-3-maxime.hadjinlian@gmail.com
State Accepted
Headers show
Series [1/5] cargo: use HOST_CARGO_DL_DIR instead of CARGO_DL_DIR | expand

Commit Message

Maxime Hadjinlian April 2, 2018, 6:36 p.m. UTC
The infrastructure only provides HOST_RUST_BIN_DL_DIR, because this
package is host only. Ideally the infra should provide RUST_BIN_DL_DIR,
but it doesn't currently, and that requires more significant changes.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/rust-bin/rust-bin.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/rust-bin/rust-bin.mk b/package/rust-bin/rust-bin.mk
index 759d468304..b57849093d 100644
--- a/package/rust-bin/rust-bin.mk
+++ b/package/rust-bin/rust-bin.mk
@@ -22,7 +22,7 @@  HOST_RUST_BIN_LIBSTD_HOST_PREFIX = rust-std-$(RUST_BIN_VERSION)-$(RUSTC_HOST_NAM
 define HOST_RUST_BIN_LIBSTD_EXTRACT
 	mkdir -p $(@D)/std
 	$(foreach f,$(HOST_RUST_BIN_EXTRA_DOWNLOADS), \
-		$(call suitable-extractor,$(f)) $(RUST_BIN_DL_DIR)/$(f) | \
+		$(call suitable-extractor,$(f)) $(HOST_RUST_BIN_DL_DIR)/$(f) | \
 			$(TAR) -C $(@D)/std $(TAR_OPTIONS) -
 	)
 	cd $(@D)/rustc/lib/rustlib; \