diff mbox series

[v2,1/2] dependencies.mk: check for valid host-tar before other host dependencies

Message ID 20180227085541.11318-1-peter@korsgaard.com
State Accepted
Commit 7c09cb82b75f30eba7a9daaae5e77a604f6e49c1
Headers show
Series [v2,1/2] dependencies.mk: check for valid host-tar before other host dependencies | expand

Commit Message

Peter Korsgaard Feb. 27, 2018, 8:55 a.m. UTC
host-{cmake,lzip,xz} needs host-tar to extract their source code tarball, so
we need to ensure that host-tar gets added to DEPENDENCIES_HOST_PREREQ
before these in case they are both needed, otherwise the tools will fail to
extract.

With the upcoming change to blacklist modern tar versions this situation is
likely to trigger more often.

The real solution to this issue is the <foo>_EXTRACT_DEPENDENCIES rework,
but that series is a bit too intrusive to add this close to 2018.02, so
therefore this hack.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
Changes since v1:
 - Issue not specific to lzip, so put tar in front of everything else

 support/dependencies/dependencies.mk | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Matt Weber Feb. 27, 2018, 2:36 p.m. UTC | #1
All,

On Tue, Feb 27, 2018 at 2:55 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
> host-{cmake,lzip,xz} needs host-tar to extract their source code tarball, so
> we need to ensure that host-tar gets added to DEPENDENCIES_HOST_PREREQ
> before these in case they are both needed, otherwise the tools will fail to
> extract.
>
> With the upcoming change to blacklist modern tar versions this situation is
> likely to trigger more often.
>
> The real solution to this issue is the <foo>_EXTRACT_DEPENDENCIES rework,
> but that series is a bit too intrusive to add this close to 2018.02, so
> therefore this hack.
>
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com>
Peter Korsgaard Feb. 27, 2018, 4:03 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > host-{cmake,lzip,xz} needs host-tar to extract their source code tarball, so
 > we need to ensure that host-tar gets added to DEPENDENCIES_HOST_PREREQ
 > before these in case they are both needed, otherwise the tools will fail to
 > extract.

 > With the upcoming change to blacklist modern tar versions this situation is
 > likely to trigger more often.

 > The real solution to this issue is the <foo>_EXTRACT_DEPENDENCIES rework,
 > but that series is a bit too intrusive to add this close to 2018.02, so
 > therefore this hack.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
 > ---
 > Changes since v1:
 >  - Issue not specific to lzip, so put tar in front of everything else

Committed, thanks.
Peter Korsgaard April 10, 2018, 8:49 p.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > host-{cmake,lzip,xz} needs host-tar to extract their source code tarball, so
 > we need to ensure that host-tar gets added to DEPENDENCIES_HOST_PREREQ
 > before these in case they are both needed, otherwise the tools will fail to
 > extract.

 > With the upcoming change to blacklist modern tar versions this situation is
 > likely to trigger more often.

 > The real solution to this issue is the <foo>_EXTRACT_DEPENDENCIES rework,
 > but that series is a bit too intrusive to add this close to 2018.02, so
 > therefore this hack.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
 > ---
 > Changes since v1:
 >  - Issue not specific to lzip, so put tar in front of everything else

Committed to 2017.02.x, thanks.
diff mbox series

Patch

diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index 4f606f849d..3fc235863c 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -12,7 +12,10 @@ 
 define suitable-host-package
 $(shell support/dependencies/check-host-$(1).sh $(2))
 endef
--include $(sort $(wildcard support/dependencies/check-host-*.mk))
+# host utilities needs host-tar to extract the source code tarballs, so
+# ensure check-host-tar.mk is included before the rest
+include support/dependencies/check-host-tar.mk
+-include $(sort $(filter-out %-tar.mk,$(wildcard support/dependencies/check-host-*.mk)))
 
 ifeq ($(BR2_CCACHE),y)
 DEPENDENCIES_HOST_PREREQ += host-ccache