diff mbox series

[next,v2] waf: bump to 2.0.6

Message ID 20180219134838.6073-1-aduskett@gmail.com
State Changes Requested
Headers show
Series [next,v2] waf: bump to 2.0.6 | expand

Commit Message

Adam Duskett Feb. 19, 2018, 1:48 p.m. UTC
In addition:
- Download the tar.bz2 package instead of just the file. The tar
  includes waf-light which is needed to parse the license.

- Remove HOST_WAF_EXTRACT_CMDS as the make system can handle extracting
  the tar.bz2 automatically.

- Add license and license_files to waf.mk

- Add sha256sum hash for the license.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
Changes v1 -> v2:
  - Changed License to BSD-3-Clause (Baruch)
  - Use waf-light instead of waf for license file. (Baruch)

 package/waf/waf.hash |  6 ++++--
 package/waf/waf.mk   | 12 +++++-------
 2 files changed, 9 insertions(+), 9 deletions(-)

Comments

Thomas Petazzoni Feb. 25, 2018, 9:58 p.m. UTC | #1
Hello,

On Mon, 19 Feb 2018 08:48:38 -0500, Adam Duskett wrote:
> In addition:
> - Download the tar.bz2 package instead of just the file. The tar
>   includes waf-light which is needed to parse the license.
> 
> - Remove HOST_WAF_EXTRACT_CMDS as the make system can handle extracting
>   the tar.bz2 automatically.
> 
> - Add license and license_files to waf.mk
> 
> - Add sha256sum hash for the license.
> 
> Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ---
> Changes v1 -> v2:
>   - Changed License to BSD-3-Clause (Baruch)
>   - Use waf-light instead of waf for license file. (Baruch)

Thanks, but this bump breaks the build of mpv (which uses waf). During
the mpv installation step, the build fails with:

Waf: Leaving directory `/home/thomas/projets/buildroot/output/build/mpv-0.27.0/build'
'install' finished successfully (0.366s)
mpv: installs files in /home/thomas/projets/buildroot/output/target//home/thomas/projets/buildroot/output
make[1]: *** [package/pkg-generic.mk:336: /home/thomas/projets/buildroot/output/build/mpv-0.27.0/.stamp_target_installed] Error 1

Reverting the waf bump fixes the problem. Here is the defconfig used to
reproduce the problem:

BR2_arm=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_TOOLCHAIN_EXTERNAL_CUSTOM=y
BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD=y
BR2_TOOLCHAIN_EXTERNAL_URL="http://autobuild.buildroot.org/toolchains/tarballs/br-arm-full-2017.11-rc1.tar.bz2"
BR2_TOOLCHAIN_EXTERNAL_GCC_4_9=y
BR2_TOOLCHAIN_EXTERNAL_HEADERS_3_10=y
BR2_TOOLCHAIN_EXTERNAL_LOCALE=y
# BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS_DEBUG is not set
BR2_TOOLCHAIN_EXTERNAL_CXX=y
BR2_INIT_NONE=y
BR2_SYSTEM_BIN_SH_NONE=y
# BR2_PACKAGE_BUSYBOX is not set
BR2_PACKAGE_MPV=y
# BR2_TARGET_ROOTFS_TAR is not set

Could you have a look at this ?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/waf/waf.hash b/package/waf/waf.hash
index 9d610b2c1e..3e887248d1 100644
--- a/package/waf/waf.hash
+++ b/package/waf/waf.hash
@@ -1,3 +1,5 @@ 
 # Locally computed
-sha1    33d170c738ed8c92dda2945b445272972f558244                          waf-1.9.5
-sha256  101f14e0f47a6410c00b8feda094948516cd3989491c56eb8268907fcd164909  waf-1.9.5
+sha1    dc5fe90642350c72f4934871f78b360d39419774                          waf-2.0.6.tar.bz2
+sha256  188d4cfc88b9e3555a197baf8a27c5f3ddeb632e2fea446416174410a804d4f3  waf-2.0.6.tar.bz2
+# License
+sha256  92bee884f4c2a302522a8322d38b720331c42da60b120f5bcd15958961b744e9  waf-light
diff --git a/package/waf/waf.mk b/package/waf/waf.mk
index e7ac891b39..039c7c4d4e 100644
--- a/package/waf/waf.mk
+++ b/package/waf/waf.mk
@@ -4,13 +4,11 @@ 
 #
 ################################################################################
 
-WAF_VERSION = 1.9.5
-WAF_SOURCE = waf-$(WAF_VERSION)
-WAF_SITE = https://waf.io/
-
-define HOST_WAF_EXTRACT_CMDS
-	$(INSTALL) -D -m 0755 $(DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf
-endef
+WAF_VERSION = 2.0.6
+WAF_SOURCE = waf-$(WAF_VERSION).tar.bz2
+WAF_SITE = https://waf.io
+WAF_LICENSE = BSD-3-Clause
+WAF_LICENSE_FILES = waf-light
 
 define HOST_WAF_INSTALL_CMDS
 	$(INSTALL) -D -m 0755 $(@D)/waf $(HOST_DIR)/bin/waf