diff mbox series

[v2,1/1] vte: new package

Message ID 20180116231558.7316-1-stefan.froberg@petroprogram.com
State Accepted
Headers show
Series [v2,1/1] vte: new package | expand

Commit Message

Stefan Fröberg Jan. 16, 2018, 11:15 p.m. UTC
The VTE package contains a termcap file implementation for 
terminal emulators. 

Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
---

Changes v1 -> v2:

- Fixed license
- Added hash file
- Added comment to Config.in (by Thomas Petazzoni)
- Added "depends on" lines needed by libgtk3 (by Thomas Petazzoni)

 DEVELOPERS            |  1 +
 package/Config.in     |  1 +
 package/vte/Config.in | 34 ++++++++++++++++++++++++++++++++++
 package/vte/vte.hash  |  3 +++
 package/vte/vte.mk    | 15 +++++++++++++++
 5 files changed, 54 insertions(+)
 create mode 100644 package/vte/Config.in
 create mode 100644 package/vte/vte.hash
 create mode 100644 package/vte/vte.mk

Comments

Adam Duskett Jan. 23, 2018, 11:49 a.m. UTC | #1
Hello;

On Tue, Jan 16, 2018 at 6:15 PM, Stefan Fröberg
<stefan.froberg@petroprogram.com> wrote:
> The VTE package contains a termcap file implementation for
> terminal emulators.
>
> Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
> ---
>
> Changes v1 -> v2:
>
> - Fixed license
> - Added hash file
> - Added comment to Config.in (by Thomas Petazzoni)
> - Added "depends on" lines needed by libgtk3 (by Thomas Petazzoni)
>
>  DEVELOPERS            |  1 +
>  package/Config.in     |  1 +
>  package/vte/Config.in | 34 ++++++++++++++++++++++++++++++++++
>  package/vte/vte.hash  |  3 +++
>  package/vte/vte.mk    | 15 +++++++++++++++
>  5 files changed, 54 insertions(+)
>  create mode 100644 package/vte/Config.in
>  create mode 100644 package/vte/vte.hash
>  create mode 100644 package/vte/vte.mk
>
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 2f7d051e8a..0f81b7093b 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1642,6 +1642,7 @@ N:        Stefan Fröberg <stefan.froberg@petroprogram.com>
>  F:     package/elfutils/
>  F:     package/libtasn1/
>  F:     package/proxychains-ng/
> +F:     package/vte/
>  F:     package/yasm/
>  F:     package/zlib-ng/
>
> diff --git a/package/Config.in b/package/Config.in
> index 01f4095be5..be0304442a 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -333,6 +333,7 @@ comment "X applications"
>         source "package/qt-webkit-kiosk/Config.in"
>         source "package/rdesktop/Config.in"
>         source "package/synergy/Config.in"
> +       source "package/vte/Config.in"
>         source "package/wmctrl/Config.in"
>         source "package/x11vnc/Config.in"
>         source "package/xdotool/Config.in"
> diff --git a/package/vte/Config.in b/package/vte/Config.in
> new file mode 100644
> index 0000000000..43c6dd0948
> --- /dev/null
> +++ b/package/vte/Config.in
> @@ -0,0 +1,34 @@
> +config BR2_PACKAGE_VTE
> +       bool "vte"
> +       depends on BR2_USE_WCHAR
> +       depends on BR2_TOOLCHAIN_HAS_THREADS
> +       depends on BR2_USE_MMU
> +       depends on BR2_INSTALL_LIBSTDCPP
> +       depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +       depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
> +               BR2_PACKAGE_HAS_LIBGL
> +       depends on BR2_PACKAGE_XORG7
> +       select BR2_PACKAGE_LIBGTK3
> +       select BR2_PACKAGE_LIBXML2
> +       select BR2_PACKAGE_PCRE2
> +       help
> +         VTE is a library (libvte) implementing a terminal emulator
> +         widget for GTK+, and a minimal sample application (vte)
> +         using that. Vte is mainly used in gnome-terminal, but
> +         can also be used to embed a console/terminal in games,
> +         editors, IDEs, etc.
> +
> +         http://github.com/GNOME/vte
> +
> +comment "vte needs a toolchain w/ wchar, threads, C++"
> +       depends on BR2_USE_MMU
> +       depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +       depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
> +               !BR2_TOOLCHAIN_HAS_THREADS
> +
> +comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
> +       depends on BR2_USE_MMU
> +       depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +       depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \
> +               !BR2_PACKAGE_HAS_LIBGL
> +
There is a blank line here. A handy trick is to always run the package
through check-package
before submitting the patch.

./utils/check-package package/vte/*
package/vte/Config.in:34: empty line at end of file
52 lines processed
1 warnings generated

> diff --git a/package/vte/vte.hash b/package/vte/vte.hash
> new file mode 100644
> index 0000000000..3fbc5acab0
> --- /dev/null
> +++ b/package/vte/vte.hash
> @@ -0,0 +1,3 @@
> +# Locally calculated
> +sha256 a3a9fb182740b392a45cd3f46fa61a985f68bb6b1817b52daec22034c46158c3  vte-0.48.3.tar.xz
> +sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
> diff --git a/package/vte/vte.mk b/package/vte/vte.mk
> new file mode 100644
> index 0000000000..85f73bb91e
> --- /dev/null
> +++ b/package/vte/vte.mk
> @@ -0,0 +1,15 @@
> +################################################################################
> +#
> +# vte
> +#
> +################################################################################
> +
> +VTE_VERSION = 0.48.3
> +VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
> +VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
> +VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
> +VTE_LICENSE = LGPL-2.1-or-later
> +VTE_LICENSE_FILES = COPYING
> +VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
> +
> +$(eval $(autotools-package))
> --
> 2.13.6
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

Cheers!

Adam
Marcus Folkesson Jan. 31, 2018, 3:09 p.m. UTC | #2
Hi Stefan,

On Wed, Jan 17, 2018 at 01:15:58AM +0200, Stefan Fröberg wrote:
> The VTE package contains a termcap file implementation for 
> terminal emulators. 
> 
> Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
> ---
> 
> Changes v1 -> v2:
> 
> - Fixed license
> - Added hash file
> - Added comment to Config.in (by Thomas Petazzoni)
> - Added "depends on" lines needed by libgtk3 (by Thomas Petazzoni)
> 
>  DEVELOPERS            |  1 +
>  package/Config.in     |  1 +
>  package/vte/Config.in | 34 ++++++++++++++++++++++++++++++++++
>  package/vte/vte.hash  |  3 +++
>  package/vte/vte.mk    | 15 +++++++++++++++
>  5 files changed, 54 insertions(+)
>  create mode 100644 package/vte/Config.in
>  create mode 100644 package/vte/vte.hash
>  create mode 100644 package/vte/vte.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 2f7d051e8a..0f81b7093b 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1642,6 +1642,7 @@ N:	Stefan Fröberg <stefan.froberg@petroprogram.com>
>  F:	package/elfutils/
>  F:	package/libtasn1/
>  F:	package/proxychains-ng/
> +F:	package/vte/
>  F:	package/yasm/
>  F:	package/zlib-ng/
>  
> diff --git a/package/Config.in b/package/Config.in
> index 01f4095be5..be0304442a 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -333,6 +333,7 @@ comment "X applications"
>  	source "package/qt-webkit-kiosk/Config.in"
>  	source "package/rdesktop/Config.in"
>  	source "package/synergy/Config.in"
> +	source "package/vte/Config.in"
>  	source "package/wmctrl/Config.in"
>  	source "package/x11vnc/Config.in"
>  	source "package/xdotool/Config.in"
> diff --git a/package/vte/Config.in b/package/vte/Config.in
> new file mode 100644
> index 0000000000..43c6dd0948
> --- /dev/null
> +++ b/package/vte/Config.in
> @@ -0,0 +1,34 @@
> +config BR2_PACKAGE_VTE
> +	bool "vte"
> +	depends on BR2_USE_WCHAR
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	depends on BR2_USE_MMU
> +	depends on BR2_INSTALL_LIBSTDCPP
> +	depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +	depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
> +		BR2_PACKAGE_HAS_LIBGL
> +	depends on BR2_PACKAGE_XORG7
> +	select BR2_PACKAGE_LIBGTK3
> +	select BR2_PACKAGE_LIBXML2
> +	select BR2_PACKAGE_PCRE2
> +	help
> +	  VTE is a library (libvte) implementing a terminal emulator
> +	  widget for GTK+, and a minimal sample application (vte)
> +	  using that. Vte is mainly used in gnome-terminal, but
> +	  can also be used to embed a console/terminal in games,
> +	  editors, IDEs, etc.
> +
> +	  http://github.com/GNOME/vte
> +
> +comment "vte needs a toolchain w/ wchar, threads, C++"
> +	depends on BR2_USE_MMU
> +	depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +	depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
> +		!BR2_TOOLCHAIN_HAS_THREADS
> +
> +comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
> +	depends on BR2_USE_MMU
> +	depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +	depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \
> +		!BR2_PACKAGE_HAS_LIBGL
> +
> diff --git a/package/vte/vte.hash b/package/vte/vte.hash
> new file mode 100644
> index 0000000000..3fbc5acab0
> --- /dev/null
> +++ b/package/vte/vte.hash
> @@ -0,0 +1,3 @@
> +# Locally calculated
> +sha256	a3a9fb182740b392a45cd3f46fa61a985f68bb6b1817b52daec22034c46158c3  vte-0.48.3.tar.xz
> +sha256	dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
> diff --git a/package/vte/vte.mk b/package/vte/vte.mk
> new file mode 100644
> index 0000000000..85f73bb91e
> --- /dev/null
> +++ b/package/vte/vte.mk
> @@ -0,0 +1,15 @@
> +################################################################################
> +#
> +# vte
> +#
> +################################################################################
> +
> +VTE_VERSION = 0.48.3
> +VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
> +VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
> +VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
> +VTE_LICENSE = LGPL-2.1-or-later

The license is LGPL-2.1, no "or-later" on this one.

> +VTE_LICENSE_FILES = COPYING
> +VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
> +
> +$(eval $(autotools-package))
> -- 
> 2.13.6
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot


Best regards
Marcus Folkesson
Thomas Petazzoni April 28, 2018, 9:30 p.m. UTC | #3
Hello,

On Wed, 31 Jan 2018 16:09:53 +0100, Marcus Folkesson wrote:

> > +VTE_LICENSE = LGPL-2.1-or-later  
> 
> The license is LGPL-2.1, no "or-later" on this one.

I don't know where you have seen this, but it seems incorrect, and
Stefan's patch is good. All license files say:

 * This library is free software; you can redistribute it and/or
 * modify it under the terms of the GNU Lesser General Public
 * License as published by the Free Software Foundation; either
 * version 2.1 of the License, or (at your option) any later version.

So the license is really LGPLv2.1 or later.

However, our encoding for the "or later" in Buildroot currently doesn't
comply with SPDX. I.e we use LGPL-2.1+ and not LGPL-2.1-or-later. I'll
fix that up when applying.

Best regards,

Thomas
Thomas Petazzoni April 28, 2018, 9:34 p.m. UTC | #4
Hello,

On Wed, 17 Jan 2018 01:15:58 +0200, Stefan Fröberg wrote:

> diff --git a/package/vte/Config.in b/package/vte/Config.in
> new file mode 100644
> index 0000000000..43c6dd0948
> --- /dev/null
> +++ b/package/vte/Config.in
> @@ -0,0 +1,34 @@
> +config BR2_PACKAGE_VTE
> +	bool "vte"
> +	depends on BR2_USE_WCHAR
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	depends on BR2_USE_MMU
> +	depends on BR2_INSTALL_LIBSTDCPP
> +	depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +	depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
> +		BR2_PACKAGE_HAS_LIBGL
> +	depends on BR2_PACKAGE_XORG7

To be honest, I'm starting to wonder if a "depends on
BR2_PACKAGE_LIBGTK3" wouldn't make much sense in such situations. It is
likely that someone wanting to use "vte" will know that he needs
libgtk3.

But OK, I've kept it as-is.
> +comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
> +	depends on BR2_USE_MMU
> +	depends on BR2_TOOLCHAIN_HAS_SYNC_4
> +	depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \
> +		!BR2_PACKAGE_HAS_LIBGL
> +

There was an empty new line here, which I removed.

> +VTE_VERSION = 0.48.3
> +VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
> +VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
> +VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
> +VTE_LICENSE = LGPL-2.1-or-later

Changed this to LGPL-2.1+, as per our conventions.

And applied. Thanks!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 2f7d051e8a..0f81b7093b 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1642,6 +1642,7 @@  N:	Stefan Fröberg <stefan.froberg@petroprogram.com>
 F:	package/elfutils/
 F:	package/libtasn1/
 F:	package/proxychains-ng/
+F:	package/vte/
 F:	package/yasm/
 F:	package/zlib-ng/
 
diff --git a/package/Config.in b/package/Config.in
index 01f4095be5..be0304442a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -333,6 +333,7 @@  comment "X applications"
 	source "package/qt-webkit-kiosk/Config.in"
 	source "package/rdesktop/Config.in"
 	source "package/synergy/Config.in"
+	source "package/vte/Config.in"
 	source "package/wmctrl/Config.in"
 	source "package/x11vnc/Config.in"
 	source "package/xdotool/Config.in"
diff --git a/package/vte/Config.in b/package/vte/Config.in
new file mode 100644
index 0000000000..43c6dd0948
--- /dev/null
+++ b/package/vte/Config.in
@@ -0,0 +1,34 @@ 
+config BR2_PACKAGE_VTE
+	bool "vte"
+	depends on BR2_USE_WCHAR
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	depends on BR2_USE_MMU
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4
+	depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
+		BR2_PACKAGE_HAS_LIBGL
+	depends on BR2_PACKAGE_XORG7
+	select BR2_PACKAGE_LIBGTK3
+	select BR2_PACKAGE_LIBXML2
+	select BR2_PACKAGE_PCRE2
+	help
+	  VTE is a library (libvte) implementing a terminal emulator
+	  widget for GTK+, and a minimal sample application (vte)
+	  using that. Vte is mainly used in gnome-terminal, but
+	  can also be used to embed a console/terminal in games,
+	  editors, IDEs, etc.
+
+	  http://github.com/GNOME/vte
+
+comment "vte needs a toolchain w/ wchar, threads, C++"
+	depends on BR2_USE_MMU
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4
+	depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
+		!BR2_TOOLCHAIN_HAS_THREADS
+
+comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
+	depends on BR2_USE_MMU
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4
+	depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \
+		!BR2_PACKAGE_HAS_LIBGL
+
diff --git a/package/vte/vte.hash b/package/vte/vte.hash
new file mode 100644
index 0000000000..3fbc5acab0
--- /dev/null
+++ b/package/vte/vte.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256	a3a9fb182740b392a45cd3f46fa61a985f68bb6b1817b52daec22034c46158c3  vte-0.48.3.tar.xz
+sha256	dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
diff --git a/package/vte/vte.mk b/package/vte/vte.mk
new file mode 100644
index 0000000000..85f73bb91e
--- /dev/null
+++ b/package/vte/vte.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# vte
+#
+################################################################################
+
+VTE_VERSION = 0.48.3
+VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
+VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
+VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
+VTE_LICENSE = LGPL-2.1-or-later
+VTE_LICENSE_FILES = COPYING
+VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
+
+$(eval $(autotools-package))