diff mbox series

uboot: add option customizing the name of environment image

Message ID 20171218145557.19360-1-didin@synopsys.com
State Rejected
Headers show
Series uboot: add option customizing the name of environment image | expand

Commit Message

Evgeniy Didin Dec. 18, 2017, 2:55 p.m. UTC
Historically, in buildroot the name of binary environment image
file is "uboot-env.bin". But in upstream u-boot default name
for this file is "uboot.env":

http://git.denx.de/?p=u-boot.git;a=blob;f=env/Kconfig#l394

For some boards U-Boot environment is stored in FAT partition, not as
a raw blob on SD-card, so the name of environment file must be correct.
For customizing name of envimage file option BR2_TARGET_UBOOT_ENVIMAGE_FILENAME
has been added. For backward compatibility by default value of this
option is set to "uboot-env.bin".

Signed-off-by: Evgeniy Didin <didin@synopsys.com>
Cc: Alexey Brodkin <abrodkin@synopsys.com>
Cc: arc-buildroot@synopsys.com
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 boot/uboot/Config.in | 8 ++++++++
 boot/uboot/uboot.mk  | 2 +-
 2 files changed, 9 insertions(+), 1 deletion(-)

Comments

Bryce Ferguson Feb. 6, 2018, 4:28 p.m. UTC | #1
Evgeniy,

On Mon, Dec 18, 2017 at 8:55 AM, Evgeniy Didin
<Evgeniy.Didin@synopsys.com> wrote:
> Historically, in buildroot the name of binary environment image
> file is "uboot-env.bin". But in upstream u-boot default name
> for this file is "uboot.env":
>
> http://git.denx.de/?p=u-boot.git;a=blob;f=env/Kconfig#l394
>
> For some boards U-Boot environment is stored in FAT partition, not as
> a raw blob on SD-card, so the name of environment file must be correct.
> For customizing name of envimage file option BR2_TARGET_UBOOT_ENVIMAGE_FILENAME
> has been added. For backward compatibility by default value of this
> option is set to "uboot-env.bin".
>
> Signed-off-by: Evgeniy Didin <didin@synopsys.com>

Reviewed-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com>
Thomas Petazzoni April 1, 2018, 10:38 p.m. UTC | #2
Hello,

On Mon, 18 Dec 2017 17:55:57 +0300, Evgeniy Didin wrote:
> Historically, in buildroot the name of binary environment image
> file is "uboot-env.bin". But in upstream u-boot default name
> for this file is "uboot.env":
> 
> http://git.denx.de/?p=u-boot.git;a=blob;f=env/Kconfig#l394
> 
> For some boards U-Boot environment is stored in FAT partition, not as
> a raw blob on SD-card, so the name of environment file must be correct.
> For customizing name of envimage file option BR2_TARGET_UBOOT_ENVIMAGE_FILENAME
> has been added. For backward compatibility by default value of this
> option is set to "uboot-env.bin".
> 
> Signed-off-by: Evgeniy Didin <didin@synopsys.com>
> Cc: Alexey Brodkin <abrodkin@synopsys.com>
> Cc: arc-buildroot@synopsys.com
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  boot/uboot/Config.in | 8 ++++++++
>  boot/uboot/uboot.mk  | 2 +-
>  2 files changed, 9 insertions(+), 1 deletion(-)

In the mean time, we merged the ARC HS Development Kit development kit,
and the rename of the u-boot environment image is done directly by
genimage:

+image boot.vfat {
+  vfat {
+    files = {
+      "uImage"
+    }
+    file uboot.env {
+      image = "uboot-env.bin"
+    }
+  }
+  size = 100M
+}

This makes this patch no longer useful, so I've marked it as Rejected
in our patch tracking system. Let me know if you disagree for some
reason. Thanks!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 2829d2ca5e..e05ae15238 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -430,6 +430,14 @@  config BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT
 	  Buildroot is compatible with the "redundant environment"
 	  mechanism of U-Boot.
 
+config BR2_TARGET_UBOOT_ENVIMAGE_FILENAME
+	string "Custom filename for environment image"
+	default "uboot-env.bin"
+	help
+	  Some platforms require setting custom name for U-Boot
+	  environment image. For backward compatibility
+	  default filename is "uboot-env.bin".
+
 endif # BR2_TARGET_UBOOT_ENVIMAGE
 
 config BR2_TARGET_UBOOT_BOOT_SCRIPT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index d2f241cd8b..5ebd1df89d 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -250,7 +250,7 @@  define UBOOT_GENERATE_ENV_IMAGE
 	$(HOST_DIR)/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
 		$(if $(BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT),-r) \
 		$(if $(filter BIG,$(BR2_ENDIAN)),-b) \
-		-o $(BINARIES_DIR)/uboot-env.bin \
+		-o $(BINARIES_DIR)/$(BR2_TARGET_UBOOT_ENVIMAGE_FILENAME) \
 		$(@D)/buildroot-env.txt
 endef
 endif