diff mbox series

[2/2] dnsmasq: Disable CHAOS by default

Message ID 20171005072532.21720-1-jer@airfi.aero
State Changes Requested
Headers show
Series None | expand

Commit Message

Jeroen Roovers Oct. 5, 2017, 7:25 a.m. UTC
dnsmasq exposes its version and some statistics through DNS, a features
that is configurable only at build time and is enabled by default.
---
 package/dnsmasq/Config.in  | 6 ++++++
 package/dnsmasq/dnsmasq.mk | 4 ++++
 2 files changed, 10 insertions(+)

Comments

Baruch Siach Oct. 5, 2017, 7:07 p.m. UTC | #1
Hi Jeroen,

On Thu, Oct 05, 2017 at 09:25:32AM +0200, Jeroen Roovers wrote:
> dnsmasq exposes its version and some statistics through DNS, a features
> that is configurable only at build time and is enabled by default.

Your sign-off is missing.

> ---
>  package/dnsmasq/Config.in  | 6 ++++++
>  package/dnsmasq/dnsmasq.mk | 4 ++++
>  2 files changed, 10 insertions(+)
> 
> diff --git a/package/dnsmasq/Config.in b/package/dnsmasq/Config.in
> index 8921fc629d..ea733d964e 100644
> --- a/package/dnsmasq/Config.in
> +++ b/package/dnsmasq/Config.in
> @@ -27,6 +27,12 @@ config BR2_PACKAGE_DNSMASQ_DNSSEC
>  	help
>  	  Enable DNSSEC validation and caching support.
>  
> +config BR2_PACKAGE_DNSMASQ_CHAOS
> +	bool "Enable identification support"
> +	default n

This is the default for kconfig symbols.

> +	help
> +	  Report *.bind CHAOS info to clients.
> +
>  config BR2_PACKAGE_DNSMASQ_IDN
>  	bool "IDN support"
>  	depends on BR2_USE_WCHAR
> diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
> index 9f96030eb6..dd2b5eb615 100644
> --- a/package/dnsmasq/dnsmasq.mk
> +++ b/package/dnsmasq/dnsmasq.mk
> @@ -30,6 +30,10 @@ ifneq ($(BR2_PACKAGE_DNSMASQ_TFTP),y)
>  DNSMASQ_COPTS += -DNO_TFTP
>  endif
>  
> +ifneq ($(BR2_PACKAGE_DNSMASQ_CHAOS),y)
> +DNSMASQ_COPTS += -DNO_ID
> +endif
> +
>  # NLS requires IDN so only enable it (i18n) when IDN is true
>  ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
>  DNSMASQ_DEPENDENCIES += libidn $(TARGET_NLS_DEPENDENCIES)

baruch
diff mbox series

Patch

diff --git a/package/dnsmasq/Config.in b/package/dnsmasq/Config.in
index 8921fc629d..ea733d964e 100644
--- a/package/dnsmasq/Config.in
+++ b/package/dnsmasq/Config.in
@@ -27,6 +27,12 @@  config BR2_PACKAGE_DNSMASQ_DNSSEC
 	help
 	  Enable DNSSEC validation and caching support.
 
+config BR2_PACKAGE_DNSMASQ_CHAOS
+	bool "Enable identification support"
+	default n
+	help
+	  Report *.bind CHAOS info to clients.
+
 config BR2_PACKAGE_DNSMASQ_IDN
 	bool "IDN support"
 	depends on BR2_USE_WCHAR
diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
index 9f96030eb6..dd2b5eb615 100644
--- a/package/dnsmasq/dnsmasq.mk
+++ b/package/dnsmasq/dnsmasq.mk
@@ -30,6 +30,10 @@  ifneq ($(BR2_PACKAGE_DNSMASQ_TFTP),y)
 DNSMASQ_COPTS += -DNO_TFTP
 endif
 
+ifneq ($(BR2_PACKAGE_DNSMASQ_CHAOS),y)
+DNSMASQ_COPTS += -DNO_ID
+endif
+
 # NLS requires IDN so only enable it (i18n) when IDN is true
 ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
 DNSMASQ_DEPENDENCIES += libidn $(TARGET_NLS_DEPENDENCIES)